Announcement: Upgrade to macOS Mojave

With features like Dark Mode, Stacks, and four new built-in apps, macOS Mojave helps you get more out of every click. 
Find out how to upgrade to macOS Mojave > https://support.apple.com/macos/mojave

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: How to stop mail from automatically editing SMTP servers?

Hi, I've been having some trouble with the built-in Mail application on my MacBook Pro with Retina Display for the past a couple of months. Incoming mails work normally but I have trouble sending emails using my 163 account. It keeps giving me the following error message and asking me to select a server

"This message could not be sent because your account does not have a preferred outgoing mail server. Select an outgoing mail server from the list below."

User uploaded file

I have tried to select the server in Mail/Preferences/Server Setting/Outgoing Mail Account. But it won't remember my choices and will reset to "None" after a couple of seconds:

User uploaded file


The official site of site instructed that the outgoing server needs to be updated from the default "applesmtp.163.com" to "smtp.163.com". And I did uncheck "Automatically manage connection settings" and enter the actual account and password. However, no matter how many times I try, it either reverts to the default or creates a duplicate of the default... 😟

User uploaded file

I think the problem is Mail keeps automatically setting the SMTP server, but I have no idea how to stop it. I have this problem for both my gmail account and my 163 account. The smpt server list window no longer has a box “Automatically detect and maintain account settings” for me to un-check. And if I try to set to for too many times, Mail will crash.


This is really driving me nuts because I have to open the webpage and log in whenever I need to send a reply. I truly appreciate any advice or help!

MacBook Pro with Retina display, macOS High Sierra (10.13.3), null

Posted on

Reply

Feb 27, 2018 6:04 AM in response to al122 In response to al122

If your iCloud account is not connected ( just an example ) , open mail application click on I cloud and send a mail from - iCloud address ( in To - field type your gmail address ) the mail will be sent to your inbox in your apple mail application a pop up appears .in this screen shot it is showing could not connect to outgoing server , thats the reason when connection doctor is opened SMTP for iCloud is totally vanished .You can apply same with gmail say if IMAP or SMTP is not working . Simply click on always use this server to get joined .

And you will observe all IMAP / SMTP for gmail account and iCloud account are showing green dots and joined to their respective server .

User uploaded file

Feb 27, 2018 6:04 AM

Reply Helpful

Feb 27, 2018 6:31 AM in response to tygb In response to tygb

Hi! Thanks for the tip! I’ve tried clicking “always use this server” and it won’t work. The problem is, whenever I edit the SMTP list to the right configuration, the settings won’t even stay until I have a chance to choose the server.

Feb 27, 2018 6:31 AM

Reply Helpful

Feb 27, 2018 6:50 AM in response to al122 In response to al122

A recent changes are shown in edit server settings , previously have to fill up the credentials , now it is showing no selection it means you don't need to enter the fields manually , it will connect it automatically , even i tried to add it manually it won't accept , but if connection doctor is opened it shows green dots for all IMAP and SMTP .

User uploaded file

And what mail help says .


User uploaded file

User uploaded file

Feb 27, 2018 6:50 AM

Reply Helpful

Feb 27, 2018 9:27 AM in response to tygb In response to tygb

To respond to the first part of your reply, I had to manually set the smtp server and fill in username/password because the automatically generated host name for outgoing mails is incorrect. After editing the default with no luck, I simply created a new server by clicking the plus sign in the first screenshot you provided and named it "163 SMTP", with all the correct credentials and the configuration 163 website recommends. This time, I was able to select "163 SMTP" in Mail/Preferences/Server Setting/Outgoing Mail Account and it did not revert to none after a couple of seconds like before.


Connection doctor verified that the IMAP and SMTP connection and login to server succeeded.

User uploaded file


However, my email still could not be sent out and I got the error message below:

User uploaded file

I copied the link and the website I was directed to here for your reference:

http://mail.163.com/help/help_spam_16.htm?ip=71.163.148.15&hostid=smtp1&time=151 9751381

http://help.163.com/09/1224/17/5RAJ4LMH00753VB8.html


Basically, the error code "DT:SPM" means an email was considered SPAM due to its format, content or excessive attempts. However, I never had this problem before I installed High Sierra. Also, I can send the exact same email by going to mail.163.com and log into my account. So I think there's some problem with either how Mail communicates with the server or how Mail modifies the email in the outbox. I'd appreciate some help on this.

Feb 27, 2018 9:27 AM

Reply Helpful

Feb 27, 2018 10:45 AM in response to tygb In response to tygb

Just did that. The host name Apple provided is "applesmtp.163.com". This is the one that did not work for me - it always show up as "offline" and cannot be selected as the outgoing mail server in Mail/Preferences/Server Setting. Now it reverts to "163 SMTP" that I created as mentioned in my last reply. Before it would revert to "none". (See my original post for the issues I was having with it.)


As I mentioned in the original post, the help page on 163.com specifically instructs to change "applesmtp.163.com" to "smtp.163.com". (Reference: http://help.163.com/10/0731/11/6CTTGJMB00753VB8.html)

And when I did create "163 SMTP" with the server "smtp.163.com", at least half of the issues were solved - I was able to select "163 SMTP" in Mail/Preferences/Server Setting/Outgoing Mail Account and Connection doctor verified that the IMAP and SMTP connection and login to server succeeded.


Taking into account what mentioned above, I think Apple Mail is having some incompatibility issues in High Sierra, and I would like to know how to solve it.

Feb 27, 2018 10:45 AM

Reply Helpful
User profile for user: al122

Question: How to stop mail from automatically editing SMTP servers?