Announcement: Upgrade to macOS Mojave

With features like Dark Mode, Stacks, and four new built-in apps, macOS Mojave helps you get more out of every click. 
Find out how to upgrade to macOS Mojave > https://support.apple.com/macos/mojave

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: I've Screwed Up My Main Drive Disk Permissions!

Hi All,


I'm fairly useless on OS X, but anyway, I have a mid-2012 MacBook Pro running 10.9.5, and I just changed my Home Folder disk permissions, thinking it would stop Finder requesting a dang password every time I wanted to delete a simple file! It didn't help. Was still requesting password for any file deleting. Anyway, so I thought I'd go up a level and try it on my Macintosh HD drive. Big mistake. Now no apps respond at all. What I did was I right clicked on the Macintosh HD logo, and selected "Get Info", then scrolled right to the bottom of that Get Info thing, and unlocked the padlock. I then clicked on the cogwheel and hit "Apply To Enclosed Items". Took ages to finish, but of course now nothing works as a result. I've tried resetting the drive's disk permissions in Disk Utility, and it did loads of fixes, but no change - still, no apps open or at least report error messages when they try to start, before terminating.


Any suggestions greatly appreciated, thank you.

MacBook Pro (13-inch Mid 2012), OS X Mavericks (10.9.5)

Posted on

Reply

Feb 27, 2018 11:20 PM in response to StuMu In response to StuMu

Edit: I just thought I'd try booting in Safe mode, and now the danged thing won't even boot up - it just gets to a grey screen with an error prompt saying "Unapproved Caller. SecurityAgent may only be invoked by Apple software."


So I reboot it, same thing every time. I can't even get into it now. And I was just about to back everything up before this! The only time machine backup I have is 2 weeks old.. I would prefer not to lose 2 weeks of work.. :-/

Feb 27, 2018 11:20 PM

Reply Helpful

Feb 28, 2018 6:16 AM in response to StuMu In response to StuMu

Try booting into Recover mode

Boot holding Command-R

<About macOS Recovery - Apple Support>

Run Disk Utility from Recovery Mode and select "Repair Permissions"

If you are lucky this will fix things up.


If that does not work, then from Recover mode, re-install macOS over top of the existing macOS. This should leave your personal files alone and just give you a properly permission operating system.

Feb 28, 2018 6:16 AM

Reply Helpful

Feb 28, 2018 1:21 PM in response to BobHarris In response to BobHarris

Thanks a lot Bob. I tried rebooting with Command-R as you suggested, but Disk Utility was the newer version, where it only presents me with the First Aid button, not with any Verify or Repair Permissions options anywhere. I clicked on the First Aid button, but it said all was fine (green tick!). But it still won't boot when I restart. I also went in to the Re-Install OSX option too while I was in there, but even though I rebooted specifically with the Command-R option, it only presents me with the latest High Sierra version of OSX, which I don't want for this old machine - I only wanted to stay with the version I have on the system presently, which is 10.9.5 Mavericks. So both those options seem to have not helped so far.


Could you suggest any other ideas?

Feb 28, 2018 1:21 PM

Reply Helpful

Feb 28, 2018 2:14 PM in response to StuMu In response to StuMu

Yes Eric - absolute certainty I only booted with Command-R. Though I'm stupid, I can manage that successfully at least! :-D. Perhaps a while back I might have gone all the way up to installing High Sierra on this machine and it's recalling that somehow now, but I don't recall what was what now.


Edit: So now, I've booted into Shift-Option-Command-R for the internet recovery option as the Command-R wasn't helping, and I now have full Disk Utility back. Drive is fine and disk permissions only gives me two errors ("System/Library/CoreServices/CoreTypes.Bundle/Contents/Resources/XProtect.meta .plist"; should be -rw-r--r-- ; they are lrw-r--r-- ., and "System/Library/CoreServices/CoreTypes.Bundle/Contents/Resources/XProtect.plist "; should be -rw-r--r-- ; they are lrw-r--r-- .). There is also a Safari Help/Contents error, and a SUID error, but these two are benign enough, from what I've read. Anyway, repair permissions says it fixes them all except the SUID one, but re-scanning immediately shows the same unfixed errors again.


Then, when I close Disk Utility and opt to re-install OSX, it gives me an option only to install Mountain Lion - which is a long way back from the Mavericks 10.9.5 I was hoping to repair.

Feb 28, 2018 2:14 PM

Reply Helpful

Feb 28, 2018 4:27 PM in response to Eric Root In response to Eric Root

Hey Eric. I have rebooted with all three recovery options and experimented with them all.. I am indeed being presented with a Mountain Lion re-install screen (I apologise profusely - I was in a rush in my last reply to get the kids to school and typed Snow Leopard by mistake - like I said - fairly stupid here..), when I use either Option-Command-R, or Shift-Option-Command-R, but I only get the option of High Sierra when I use Command-R.


Anyway, can I please ask you if I do proceed with this re-install of Mountain Lion (which hopefully means I get to keep my files), can I then get it up to 10.9.5 Mavericks again somehow? I thought it would only put ML on, then give me update options for that OS only, but I'd get no further to upgrading to the Mavericks platform?


By the way - you guys are so immense.. thanks so much.

Feb 28, 2018 4:27 PM

Reply Helpful

Mar 1, 2018 2:46 PM in response to StuMu In response to StuMu

Make sure you have a backup of your disk, preferably 2 on 2 separate drives, before you do anything. To reinstall Mountain Lion, the disk will need to erased. Once Mountain Lion is installed, reboot normally and use Setup Assistant to restore your files. Then go to the App Store Purchases tab to download Mavericks. If it won't let you, find an older computer where you can sign into the App Store using your Apple ID and download it. Quit the installer. You can make a bootable USB stick to install using this free program which will do all the work for you.


Bootable USB Flash Drive – Diskmaker X oruse Apple’s method Create a bootable installer for OS

Mar 1, 2018 2:46 PM

Reply Helpful

Mar 5, 2018 9:19 PM in response to StuMu In response to StuMu

In the end, the quickest solution for me was to just install another fresh SSD drive, and revert to my 2 week old Time Machine backup. As the permissions-corrupted original drive was still accessible as an external drive, I just copied all my files from the previous two weeks of work from it and put them on the new drive, so I lost nothing in the end. But at least now I know not to unlock the main drive and change its system permissions. Was only trying to do that to stop Finder from constantly requiring a password to just delete basic files. Clearly that wasn't the solution. Will keep looking. Thanks Eric for your help.

Mar 5, 2018 9:19 PM

Reply Helpful
User profile for user: StuMu

Question: I've Screwed Up My Main Drive Disk Permissions!