Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Photos cannot find the System Photo Library

Hi all,


I'm using Photos version 3.0 (3251.12.190) on a late 2013 Mac Pro running Mac OS 10.13.3. I have an external Drobo drive array connected via Thunderbolt where my Photos library lives. I've noticed pretty much since I upgraded to High Sierra that when I first launch Photos after rebooting, I get an error message saying that "Photos cannot find the System Photo Library". When I click "Open Other..." however, I get a list showing me the System Photo Library, and if I select it to open, Photos starts normally. Every time I open Photos after that, I will get the "What's new in Photos" splash window. That is, until I reboot, when it can't find the library again. This has coincided with iTunes syncing all of my photos to my iPhone whenever I add any new images to Photos. This happens even after I have relocated the library for Photos.


None of this behavior is fatal, but it is certainly annoying (especially the waiting for 5000 photos to sync to my iPhone every time I add 1 new one). Any fixes or troubleshooting would be much appreciated.



Ted

Mac Pro, macOS High Sierra (10.13.3)

Posted on

Reply

Feb 28, 2018 3:55 PM in response to deadward In response to deadward

It probably is fatal - the Photos library can not be an any drive that is not formatted Mac OS extended (journaled) or APFS - no other format will work - Where is it safe to store a Photos Library? Requirements for the external drive - and if you use a non-confirming drive you will have problems and lose data sooner or later


LN

Feb 28, 2018 3:55 PM

Reply Helpful

Mar 1, 2018 1:11 AM in response to deadward In response to deadward

If Photos cannot remember the location of the library, it may be a problem of the preferences file.

Have you already tried to repair the permissions on your home folder, so Photos has the necessary permissions to write to your home user library?

See: Resolve issues caused by changing the permissions of items in your home folder - Apple Support


If that does not help, consider to remove the Photos preferences:

To delete the Photos preferences files:


  • Quit Photos, if it is running.
  • Open your user library in your home folder.

Delete the complete folder ~/Library/Containers/com.apple.Photos/ and restart the Mac, then try again.Your user library may still be hidden.

  • To reveal the hidden User Library:
    • Bring the Finder forward by clicking on the Desktop or the Finder icon in the Dock.
    • Select your user/home folder (with the house icon in the Finder sidebar)
    • With that Finder window as the front window, press the key combination ⌘J to bring up the View options.
    • In the View options panel enable ’Show Library Folder’. That will make your user library folder visible in your Home folder, if it is still hidden.
    • Open your Home folder, then the Library folder, then Containers.

    Move the complete folder ~/Library/Containers/com.apple.Photos to your desktop. Move the entire folder, not just the contents.

  • While you are about it, delete also ~/Library/Preferences/com.apple.Photos.plist

Restart the Mac and try again.

After you deleted the ~/Library/Containers/com.apple.Photos/ and preferences, Photos will not remember the location of the library and the preferences you set. You will have to set them again, and hopefully it will stick this time.

Mar 1, 2018 1:11 AM

Reply Helpful

Mar 1, 2018 2:19 PM in response to léonie In response to léonie

Thanks all. I tried resetting permissions and deleting the Photos preferences and plist files, but the issue persisted. I then tried creating a new Photos library on my startup drive and setting it as the System Photos Library, and that one loaded normally, even after rebooting. When I reselected the external drive library and set it as the system library, it went back to forgetting where it was after rebooting. So it's definitely something related to the library being on an external drive. I wouldn't think that the Drobo/disk array nature of the drive would matter, as to Mac OS it is presented as a normal formatted volume and the background operation of the Drobo is invisible (to my knowledge). Sadly my Photos library is way too big to fit on the internal Mac Pro drive, so until I find a solution I'll have to put up with this behavior.

Mar 1, 2018 2:19 PM

Reply Helpful

Mar 2, 2018 4:33 AM in response to deadward In response to deadward

I'm having this same problem, but with a system Photos library that's stored on an internal HDD. I believe the problem is related to whether the drive is formatted to APFS vs. HFS+, not whether it's internal or external. I'm running High Sierra 10.13.3, and my primary startup drive is an SSD that was converted to APFS. My Photos library is on a secondary internal HDD that is still on HFS+ (not a Fusion drive setup on my 2012 iMac). I get exactly the same behavior you describe.

Mar 2, 2018 4:33 AM

Reply Helpful
User profile for user: deadward

Question: Photos cannot find the System Photo Library