Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Dropbox wants new version of Lion 10.7.5

Im getting notifications from Dropbox and other apps that my OS 10.7.5 isnt high enough to use them. But my computer says its up to date?

Posted on

Reply
Question marked as Apple recommended
Answer:
Answer:

The apps are probably advising you that you need to upgrade your Mac to a newer version of macOS.

High Sierra is the latest, How to download macOS High Sierra - Apple Support

Sierra is still available, How to download macOS Sierra - Apple Support

And if your Mac is too old for those you can still get El Capitan, How to download OS X El Capitan - Apple Support

Posted on

Question marked as Apple recommended

Mar 1, 2018 9:22 PM in response to justtjo In response to justtjo

The apps are probably advising you that you need to upgrade your Mac to a newer version of macOS.

High Sierra is the latest, How to download macOS High Sierra - Apple Support

Sierra is still available, How to download macOS Sierra - Apple Support

And if your Mac is too old for those you can still get El Capitan, How to download OS X El Capitan - Apple Support

Mar 1, 2018 9:22 PM

Reply Helpful
User profile for user: justtjo

Question: Dropbox wants new version of Lion 10.7.5