Announcement: Upgrade to macOS Mojave

With features like Dark Mode, Stacks, and four new built-in apps, macOS Mojave helps you get more out of every click. 
Find out how to upgrade to macOS Mojave > https://support.apple.com/macos/mojave

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: spotlight mds segfault, mds_stores assert

Running Sierra 10.12.6 on a MBP Retina, 15inch late 2013).

I have searched everywhere, tried I think everything, but can't get spotlight indexing to stop crashing.

Mar 2 09:44:47 zv70 com.apple.xpc.launchd[1] (com.apple.metadata.mds.index[8306]): Service exited due to signal: Segmentation fault: 11 sent by exc handler[0]

and:

Mar 2 09:44:47 zv70 mds_stores[8329]: assertion failed: 16G1212: libxpc.dylib + 28737 [BF896DF0-D8E9-31A8-A4B3-01120BFEEE52]: 0xf

In Activity Monitor, I have looked at the crazy number of mdworker threads, then at their open files, trying to identify a possible bad file.

I purchased Norton Antivirus *just* to check that all files are ok (readable). This did actually fix a few files, but did not fix the issue.

I have monitored the size of the directory tree /.Spotlight-V100 using "du -s". It goes *very* slowly, then when the crash occurs, pretty clearly is all deleted.

I have restarted search using the preference-app approach (wow -- super-hokey, for years!) and:

mdutil -E /

I have removed all mdimporters in /Library/Spotlight (nothing in there now)

I have checked /System/Library/Spotlight and the mdimporters in there seem ok.

And

/usr/bin/mdimport -L

confirms what looks ok (only one MS Outlook importer).

In all of this, many system reboots (pretty much after every one of the steps above).


Any help on this would be really appreciated!

Seriously longing for days when I had Windows and X1 search.... it just worked.

MacBook Pro with Retina display, macOS Sierra (10.12.6)

Posted on

Reply

Mar 2, 2018 12:56 PM in response to Eric Root In response to Eric Root

I did see that post before; it's a combination of somewhat incorrect to start with and/or out of date.

When mdutil -E / is run (or using the settings/spotlight silly dance), that directory is deleted.

But, I have deleted /.Spotlight-V100 just for kicks. I guess I have not done that AND started in safe mode, but I have sen no other comments to support this step, and it seems kind of out there.

Mar 2, 2018 12:56 PM

Reply Helpful (2)
User profile for user: jag99

Question: spotlight mds segfault, mds_stores assert