Related Article

Use Messages on your iPhone, iPad, or iPod touch

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: My messages sent appear as from an iCloud.com instead of my number. This is a new phone that was activated 14 hours ago but wondering if it takes awhile for others to receive messages as it is coming from my stored name on their device

My messages sent appear as from an iCloud.com instead of my number. This is a new phone that was activated 14 hours ago but wondering if it takes awhile for others to receive messages as it is coming from my stored name on their device

Posted on

Reply

Mar 5, 2018 1:41 PM in response to Kamkarr In response to Kamkarr

Hello Kamkarr,


Thanks for asking the Apple Support Communities for help with your Messages. Please verify your number is added, and the one set to "Start New Conversations From" as shown in this article. Please review the entire article, but I will quote the part I am describing to you: Add or remove your phone number in Messages or FaceTime



If you can't see or select your number in Messages or FaceTime


  1. Make sure that you're using the latest software for your Mac or iOS device.
  2. Make sure that you correctly followed the iPhone steps to set up your phone number. You should be using the same Apple ID on all of your devices.
  3. In the “You can be reached” section of Messages and FaceTime settings, make sure that there are checkmarks beside your phone number and Apple ID:

User uploaded file




Thanks and have a wonderful day.

Mar 5, 2018 1:41 PM

Reply Helpful
User profile for user: Kamkarr

Question: My messages sent appear as from an iCloud.com instead of my number. This is a new phone that was activated 14 hours ago but wondering if it takes awhile for others to receive messages as it is coming from my stored name on their device