Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: CPU overload in MainStage 3

Everything is current and up to date. I have a rebuilt 2013 MacBook Pro with 16 Gb ram. 2.5 GHz Intel Core i5. Activity monitor is showing 150% usage and the CPU is maxed out in my MainStage meter. It seems both my piano plug ins are doing it. Im picky about my piano sound and I bought 2 new plug ins. I have everything in the audio preferences set to factory. I tried some buffer settings to no avail. The samples are about 150megs. When I run the plug ins as stand alone apps they work fine at 20% CPU usage. Please help. I have to use this rig live.

MainStage, OS X Yosemite (10.10)

Posted on

Reply

Mar 26, 2018 10:12 AM in response to PanicPinky In response to PanicPinky

Yea man. First try and place as much as you can in Concert level because every time you use for instance the sampler in one patch and then again in another the computer actually runs multiple versions of it in each patch. So it hogs the CPU. Then instead of muting the instruments in you patch try using bypass instead as it cuts down on CPU big time too. The down fall is that you cannot save individual settings on a concert level instrument in a patch. Im still playing with it. Good luck!

Mar 26, 2018 10:12 AM

Reply Helpful
User profile for user: Pianomonster

Question: CPU overload in MainStage 3