Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Newest Mac Mini supporting 10.6.8

What is the newest Mac Mini that will support 10.6.8? I have a number of programs that need 10.6.8 to operate correctly. I have my current Mac Mini backed up with Super Duper and would like to instal that on a newer Mac Mini. Thanks!!!!

Posted on

Reply

There’s more to the conversation

Read all replies
User profile for user: DMG102

Question: Newest Mac Mini supporting 10.6.8