Announcement: Upgrade to macOS Mojave

With features like Dark Mode, Stacks, and four new built-in apps, macOS Mojave helps you get more out of every click. 
Find out how to upgrade to macOS Mojave > https://support.apple.com/macos/mojave

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: SMS messages not syncing with Messages on High Sierra

Since upgrading my iMac to High Sierra, Messages has stopped picking up or enabling me to write SMS messages. It still handles iMessages with no problems, but this means that when communicating with phones that are not iPhones I need to read and write on my iPhone 7 itself, or on my MacBook Air, which still runs El Capitan, and is still able to sync as before. I have compared settings in both the Messages app and for iCloud and they are identical between the iMac and the MBA. Any advice on how to resolve this?

iMac (27-inch, Late 2013), macOS Sierra (10.12.4)

Posted on

Reply
Question marked as Solved
Answer:
Answer:

Have you checked the settings on your iPhone?


Go to Settings > Messages > Text Message Forwarding and make sure both your iMac and MacBook Air are enabled.

Posted on

Page content loaded

User profile for user: matthew shorter

Question: SMS messages not syncing with Messages on High Sierra