Announcement: Upgrade to macOS Mojave

With features like Dark Mode, Stacks, and four new built-in apps, macOS Mojave helps you get more out of every click. 
Find out how to upgrade to macOS Mojave > https://support.apple.com/macos/mojave

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Mail compose window WAY TOO LONG

Originally posted by DanG77...I still have this problem. Nothing has worked, including his 'fix' listed here:


Mail Window Size (compose or reply) way too BIG


Dan's orig. post: (which matches my experience) I have asked this before and gotten no response. Mail is driving me crazy. A few months ago the "new message" window and/or "reply" windows started taking up all my screen real estate, no longer opening at a smaller size. I resize the window and close it, and the next time it opens at a reasonable size. But after that, again it takes up the entire screen (and I have to manually resize it... are real pain). This also happens (the window is huge) every time I quit and open Mail again.


The solutions in the support group (deleting signatures in the Mail preferences, deleting the Mail plist file) have not solved the problem. Please Help.... this is driving me crazy

iMac, iOS 10.1.1, High Sierra IOs upgrade, iOs 10.13

Posted on

Reply

Page content loaded

Mar 9, 2018 8:30 PM in response to harmony2u In response to harmony2u

Do a backup, preferably 2 backups on 2 separate drives.


Quit the application.


Go to Finder and select your user/home folder. With that Finder window as the front window, either select Finder/View/Show View options or go command - J. When the View options opens, check ’Show Library Folder’. That should make your user library folder visible in your user/home folder. Select Library. Then go to Preferences/com.apple.mail.plist. Move the .plist to your desktop.


Restart the computer, open the application, and test. If it works okay, delete the plist from the desktop.


If the application is the same, return the .plist to where you got it from, overwriting the newer one.


Thanks to leonie for some information contained in this.

Mar 9, 2018 8:30 PM

Reply Helpful

Mar 9, 2018 8:46 PM in response to harmony2u In response to harmony2u

When mail application is opened and you compose a new mail window ( command and N ) , take cursor on top menu bar > view > click on full screen mode the compose window will take entire space of the desktop , before quitting the ,mail application the correct way is again click on view > and exit full screen mode .

Then if you want to mail some one that can be done ( by filling all credentials ) , once the mail is sent , right click on apple mail application and click on quit .

Try these steps , if it is not working accordingly then -

Delete the IMAP account by going to system preferences > internet accounts - select the account that is problematic and click on subtract sign .

The mail account will be deleted from Mac apple mail application , but all mails are stored on servers .

You can again add the account , take cursor on top menu bar > click on add accounts , a window appears select the mail service provider and click on continue .

You have to enter the web mail address , click on next > enter your password and click on done .

See this article Set up Mail on your Mac with email accounts - Apple Support

Mar 9, 2018 8:46 PM

Reply Helpful

Mar 11, 2018 9:42 PM in response to Eric Root In response to Eric Root

the window is not just too large, it is only waaaaaaaaaaaay too looooooooooooooong. So long that it surpasses the length of my IMac's screen by about 3 times.

checked my preferences and in System Preferences/General Close windows when quitting an app. was already unchecked.

Mar 11, 2018 9:42 PM

Reply Helpful

Mar 12, 2018 8:52 AM in response to harmony2u In response to harmony2u

Since the box was unchecked, try going back and checking it to see if that helps.


Try setting up another admin user account to see if the same problem continues. If Back-to-My Mac is selected in System Preferences, the Guest account will not work. The intent is to see if it is specific to one account or a system wide problem. This account can be deleted later. Please post if this worked or not.


Isolating an issue by using another user account


If the problem is still there, try booting into the Safe Mode using your normal account. Disconnect all peripherals except those needed for the test. Shut down the computer and then power it back up after waiting 10 seconds. Immediately after hearing the startup chime, hold down the shift key and continue to hold it until the gray Apple icon and a progress bar appear. The boot up is significantly slower than normal. This will reset some caches, forces a directory check, and disables all startup and login items, among other things. When you reboot normally, the initial reboot may be slower than normal. If the system operates normally, there may be 3rd party applications which are causing a problem. Try deleting/disabling the third party applications after a restart by using the application un-installer or by using the developer’s uninstall instructions. For each disable/delete, you will need to restart if you don't do them all at once. Please post if this worked or not.




Safe Mode - About El Capitan
also Sierra


Safe Mode Startup – El Capitan. also Sierra


If it works in the Safe Mode, try running this program when booted normally and then copy and paste the output in a reply. The program was created by Etresoft, a frequent contributor. Please use copy and paste as screen shots can be hard to read. Click “Share Report” button in the toolbar, select “Copy to Clipboard” and then paste into a reply. This will show what is running on your computer. No personal information is shown. You can run the report for free at least once, but if you run it several times, at some point it will ask you to pay a license fee.

Etrecheck – System Information


Mar 12, 2018 8:52 AM

Reply Helpful
User profile for user: harmony2u

Question: Mail compose window WAY TOO LONG