Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: I can't connect to HomePod from my Mac Pro

Hi All,


It seems I have stumbled across a bug. Let me explain...


I have a Mac Pro, on which I have two networks, the physical one using Ethernet as well as a WiFi one. I usually have the Ethernet network set highest in Service Order in Network settings. I basically only use the WiFi to unlock my Mac Pro from my Apple Watch, and AirPlay (I was hoping).


Now I just got a HomePod, and it works great. I can connect to it from my iPhone, iPad, as well as my MacBook Pro. However, I cannot connect to it from my Mac Pro. My Mac Pro sees it, but when I select it in Sound settings, it says it cannot connect. But, if I select the WiFi to have the higher service order in Network settings (above Ethernet), it all works fine...


That MUST be a bug, right? It certainly is a MAJOR irritation. I have no wish to have all my internet traffic go through the slower WiFi, but if I select the service order to prefer Ethernet, I cannot use my HomePod.


Any suggestions?

Mac Pro (Late 2013), macOS High Sierra (10.13), HomePod

Posted on

Reply
Question marked as Helpful

Mar 11, 2018 1:59 PM in response to bomelkr In response to bomelkr

If you turn off the Time Capsule then the HomePod cannot stream from the Internet, but it might still be visible to the MacPro, which would mean the connection isn't via the local network but is the ad hoc point to point network which anyone in the vicinity of your device could potentially use to control it. As I posted here I was able to AirPlay from my Mac to my HomePod with my Wi-Fi router's radio shut off.


tt2

Question marked as Helpful

Mar 11, 2018 1:59 PM in response to bomelkr In response to bomelkr

bomelkr wrote:

It is a bit tricky to test as I have no less than 5 WiFi networks in the house. I work in IT and test a bunch of internet connections (LTE, ADSL, BSA), and I have two separate WiFi networks for usage.


Ah, that might be the issue. When you set up the HomePod I suspect it inherits all of the wireless settings of the device you're using for setup. There is, perhaps, no guarantee that the HomePod is using a wireless network that is reachable by the wired connection from the Mac Pro under such circumstances. You'd have to interrogate the DHCP leases for each network to be certain which network the HomePod is actually using. If you forget all of your local networks apart from the TimeCapsule from the device you're using for setup, then set up the HomePod again from scratch it might work.


tt2

There’s more to the conversation

Read all replies

Page content loaded

Mar 9, 2018 1:43 PM in response to bomelkr In response to bomelkr

The Wi-Fi network would normally be an extension of your local wired network such that all devices on the wired and wireless networks can see each other, irrespective of connection method. There should only be one network, and your computer should only use one interface to connect to it. You would use wired where possible. If your move your machine from one network to the other, i.e. you have it wired in your office and then use it wirelessly elsewhere, it is quite possible that devices on your network may not find it at the expected address.


tt2

Mar 9, 2018 1:43 PM

Reply Helpful

Mar 9, 2018 2:40 PM in response to turingtest2 In response to turingtest2

I absolutely agree, but since I need to access files from my NAS, and the physical Ethernet network is so much faster, I need to use it. But the HomePod only connects via WiFi, and hence I have to use both. As soon as I turn off WiFi, or I set the service order to have WiFi second, I cannot connect to the HomePod.


Tell me another way and I will listen, but Wifi is too slow for files from my NAS, and I cannot use my HomePod via Ethernet. What to do?

Mar 9, 2018 2:40 PM

Reply Helpful

Mar 9, 2018 2:49 PM in response to bomelkr In response to bomelkr

Sounds like something going on with airplay and your router between, wifi and ethernet.

I've heard, can't do this myself, some people turning off/disabling the WMM (Wi-Fi Multimedia) on there router, if such settings exist to fix it.

Mar 9, 2018 2:49 PM

Reply Helpful

Mar 9, 2018 3:00 PM in response to evilcougar In response to evilcougar

by the way I do have a mixture of wifi and ethernet, all my mac's, pc on ethernet can detect, my homepod (wifi). which leads me to think it's got to be airplay getting blocked between wifi and ethernet

Mar 9, 2018 3:00 PM

Reply Helpful

Mar 9, 2018 3:14 PM in response to evilcougar In response to evilcougar

The plot thickens...


Even if I turn off WiFi on the Mac Pro, and when I select the HomePod in Sound settings it errors. However, I have found out that I can actually turn on iTunes, select the HomePod as the speaker in the airdrop menu, and it seems to work.


What the heck is going on?


My network goes via a Time Capsule, and I can't find anything that relates to VMM...

Mar 9, 2018 3:14 PM

Reply Helpful

Mar 9, 2018 3:41 PM in response to evilcougar In response to evilcougar

Also forgot to mention, for Speakers in Home App/HomeKit click on arrow in top left corner, I have it set to "Allow Speaker Access" "Everyone".

Mar 9, 2018 3:41 PM

Reply Helpful

Mar 9, 2018 3:59 PM in response to evilcougar In response to evilcougar

Just to experiment, if I change my "Allow Speaker Access" back to the default of "Anyone on the same Network" in Home App/HomeKit, my PC's and MAC on ethernet can no longer connect to my HomePod, but everything on wifi: macbook pro, iphone .. etc still can. changed it back to "Everyone" and all devices on ethernet can connect to HomePod again

Mar 9, 2018 3:59 PM

Reply Helpful

Mar 9, 2018 7:41 PM in response to evilcougar In response to evilcougar

OK, I set up the following network;


ADSL Modem <-> Time Capsule WAN

- Time Capsule setup for DHCP and NAT

- WiFi from Time Capsule


I connected my iPhone to the WiFi, and set up the HomePod, access to everyone. I connected my MacBook Pro to the WiFi, and I could select the HomePod in Sound settings, and all was fine.


However, when I turned off the WiFi, and connected my MacBook to the Time Capsule via Ethernet (Thunderbolt dongle), I had internet etc., but I could not see the HomePod anymore in Sound Settings. The second I turned on WiFi, the HomePod showed up again in Sound settings, and all was fine. The second I turned off WiFi, using only the Ethernet connection, the HomePod dissappeared...

Mar 9, 2018 7:41 PM

Reply Helpful

Mar 10, 2018 8:41 AM in response to turingtest2 In response to turingtest2

I went back to basics...


- Reset Time Capsule, setup WiFi network, plugged in MacBook Pro in LAN connection, nothing else, no WAN, no internet

- Reset HomePod, connected iPhone to WiFi, setup HomePod


MacBook Pro does NOT see HomePod in Sound settings. However, if I turn on WiFi on the MacBook Pro, it sees the HomePod immediately. The second I turn off WiFi and only connect to TimeCapsule via Ethernet, I can't see the HomePod.


???

Mar 10, 2018 8:41 AM

Reply Helpful

Mar 10, 2018 10:22 AM in response to bomelkr In response to bomelkr

Very odd. I assume it is some kind of routing issue, but what? 😕


Is the connection method set up for anyone on same network or everyone? If it is the latter then I suspect that when you're using wi-fi the devices are setting up an ad hoc direction connection between themselves without using the Time Capsule. As an experiment I've just switched to everyone with a passcode enabled, then disabled the wireless in my router, and I can still access my HomePod for AirPlay, although not for the remote control method I've been using here: Remote control for HomePod, not using AirPlay.


tt2

Mar 10, 2018 10:22 AM

Reply Helpful

Mar 10, 2018 12:53 PM in response to turingtest2 In response to turingtest2

Thanks for trying things out...


I thought it had something to do with NATing... But, then again not, because it didn't work either with just a Time Capsule, a MacBook Pro, an iPhone, and the HomePod, where there was no internet, and just a network set up on the Time Capsule...


I have now reverted to my usual setup, which is;


ADSL Modem (DHCP and NAT) <-> HP switch <-> Time Capsule WAN

- Ethernet between HP switch and; NAS, Mac Pro, Mac Mini, Printer, TV, AMP, BR, Time Capsule, etc.

- WiFi from Time Capsule connecting; iPhones, iPads, MacBooks, etc.


All works fine, EXCEPT I can only connect to the HomePod via WiFi. If I turn on WiFi on the Macs I can connect to and use the HomePod. However, if I turn off WiFi, I can still see the HomePod, but when I try to select it in Sound settings, I get the dreaded "Could not connect to Homepod". I also see my AMP in AirPlay, and I can connect to it fine, via Ethernet only. And funny enough, using iTunes, I can use the HomePod as a speaker via AirPlay, even on Ethernet only. What I cannot do is set the HomePod as the system speaker via Ethernet, and that means I cannot play for instance YouTube via it.

Mar 10, 2018 12:53 PM

Reply Helpful

Mar 10, 2018 1:26 PM in response to bomelkr In response to bomelkr

Try connecting the HP switch to one of the Time Capsule's LAN ports. If you're using the WAN port then in principle anything else connected to the Time Capsule can get out to the Internet, but it ought to be insulated from the rest of your network and vice versa.


tt2

Mar 10, 2018 1:26 PM

Reply Helpful
User profile for user: bomelkr

Question: I can't connect to HomePod from my Mac Pro