Announcement: Upgrade to macOS Mojave

With features like Dark Mode, Stacks, and four new built-in apps, macOS Mojave helps you get more out of every click. 
Find out how to upgrade to macOS Mojave > https://support.apple.com/macos/mojave

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: How Do You Remove old autocomplete entries in Messages

My friend has a new phone number. I've updated his contact in contacts, but the old number still shows up when I type his name in messages in High Sierra. Further more, even if I select the new number, messages will simply send it to the previous number, because it's attached to his name, and it's the number I texted to him in all previous conversations. Yeah, that's right, messages isn't even sending the text to the number I've choosen - it just sends to my my cousins name, with the old number, even though that's not saved under his contact anymore. I had to go to my iPhone and manually text him from contacts. Messages on my computer is totally messed up.

iMac, macOS Sierra (10.12.6), Mid 2011 iMac 21.5-inch

Posted on

Reply

Page content loaded

Mar 9, 2018 2:48 PM in response to Questionable Sanity In response to Questionable Sanity

Are you sure that he has re-registered his new number with iMessages? He also may not have unregistered the old number.


Deregister iMessage on your iPhone or online - Apple Support


Unfortunately, it may be a bit of a problem if he no longer has access to that phone number.

Mar 9, 2018 2:48 PM

Reply Helpful

Mar 9, 2018 2:50 PM in response to IdrisSeabright In response to IdrisSeabright

No, it's not even an imessage. I'm just trying to send him a regular text, he's never had his number registered for imessages. That's what's so screwy about this. At least now if I choose one number, it "seems" to only be texting the number I choose, but autocomplete still suggests the old number

Mar 9, 2018 2:50 PM

Reply Helpful

Mar 9, 2018 2:51 PM in response to Questionable Sanity In response to Questionable Sanity

Questionable Sanity wrote:


At least now if I choose one number, it "seems" to only be texting the number I choose, but autocomplete still suggests the old number

Yes, that's expected behavior. It will eventually be overwritten.

Mar 9, 2018 2:51 PM

Reply Helpful

Mar 10, 2018 12:47 PM in response to Questionable Sanity In response to Questionable Sanity

Hi,


As far as I can make out it cannot be done.

See Messages shows old removed phone numbers

This Link shows you where some of the info might be held but the two main places I have found don't explain the the whole options listed.


In the SOAgent helper files listed in the other thread the AIM and Yahoo ones are ignored now that the services are not listed in Messages. Bonjour ones also don't show as there are always an ID linked to another computer even though Hight Sierra does not use Bonjour in Messages.



User uploaded file

8:47 pm Saturday; March 10, 2018


 iMac 2.5Ghz i5 2011 (Sierra)
 G4/1GhzDual MDD (Leopard 10.5.8)
 MacBookPro 2Gb (Snow Leopard 10.6.8)
 Mac OS X (10.6.8),
 iPhone 6 iOS 11.x and an iPad (2)

Mar 10, 2018 12:47 PM

Reply Helpful
User profile for user: Questionable Sanity

Question: How Do You Remove old autocomplete entries in Messages