Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Yet another grey screen problem

I have a mid-2012 MacBook Pro running macOS 10.13.3.


On start up the tone sounds, the screen powers up but all I see is a grey/white background, no Apple logo or timer.


I plugged the laptop into my TV using the Mini DisplayPort and I can now see on the external screen that it is booting up normally but nothing is displayed on my laptop except the grey screen.


I've tried various things like rebooting in safe mode, disk repair through OS utilities, resetting NVRAM and resetting the system management controller all of which give the same result when restarting my Mac, unsurprisingly.


Is this problem likely to be caused by physical damage to cables or other components, or could it be a software problem? The built-in camera still works if that means anything.


Thanks all!

Posted on

Reply

There’s more to the conversation

Read all replies

Page content loaded

Question marked as Helpful

Mar 13, 2018 10:54 PM in response to JoeliVidiri In response to JoeliVidiri

When in safe mode, things work normal?


Assuming there is no problem starting from macOS Recovery, try reinstalling macOS.

Make sure you have a backup.


https://support.apple.com/en-us/HT204904

Mar 13, 2018 10:54 PM

Reply Helpful (1)

Mar 13, 2018 10:54 PM in response to dominic23 In response to dominic23

Thanks for the response.


No, things don't work normally in safe mode, in as much as the laptop screen still doesn't show anything but a grey glare. I can only see that the MacBook has actually started in safe mode (or any mode) once I plug in an external screen where I can see the prompt asking for my login.


If you think that it might solve this problem, I'll backup and reinstall macOS.


Cheers

Mar 13, 2018 10:54 PM

Reply Helpful
User profile for user: JoeliVidiri

Question: Yet another grey screen problem