Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: None of the photos or videos from My Albums appear in the Imovie media browser.

None of the photos or videos from My Albums appear in the IMovie media browser.

In addition , If I enter a search string with the name of a photo or video whilst in Album view, no images or clips are shown in the media browser.

I have a large number of images in my photos library and I need to be able to search for the clip or image by name as it is not possible to wade through all the clips to find the image / clip I need.

macOS High Sierra (10.13.2)

Posted on

Reply
Question marked as Solved
Answer:
Answer:

Try closing iMovie and reopening it.


Try opening iMovie while holding down the Option and Command keys, and selecting to delete preferences in the box that appears.


Photos in the cloud will not display in iMovie. If you have any photos in the cloud, go to the Photos app, control-click the album and select Download Originals to this Mac if that option is available. If it is not available then they are already downloaded.


Also, in Photos preferences make sure that Use as System Photo Library is selected. If it is grayed out, that means that it is already selected.


If you can't get the albums to display, you can select your albums and photos in the Photos app itself, export the ones you want to your desktop, and from there drag them into iMovie.


-- Rich

Posted on

Page content loaded

Mar 10, 2018 3:13 PM in response to fmarkriley In response to fmarkriley

Hi,


If you click on My Albums and then click on All My Albums to the right (it will look grayed out, but it works) you should see a display of all your albums by name. You can then search for a specific album by name or open an album to display its contents and search for individual photos by name.



User uploaded file


-- Rich

Mar 10, 2018 3:13 PM

Reply Helpful
Question marked as Solved

Mar 11, 2018 8:29 AM in response to fmarkriley In response to fmarkriley

Try closing iMovie and reopening it.


Try opening iMovie while holding down the Option and Command keys, and selecting to delete preferences in the box that appears.


Photos in the cloud will not display in iMovie. If you have any photos in the cloud, go to the Photos app, control-click the album and select Download Originals to this Mac if that option is available. If it is not available then they are already downloaded.


Also, in Photos preferences make sure that Use as System Photo Library is selected. If it is grayed out, that means that it is already selected.


If you can't get the albums to display, you can select your albums and photos in the Photos app itself, export the ones you want to your desktop, and from there drag them into iMovie.


-- Rich

Mar 11, 2018 8:29 AM

Reply Helpful
User profile for user: fmarkriley

Question: None of the photos or videos from My Albums appear in the Imovie media browser.