Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: HomePod & Apple TV 4K HomeKit - Disconnected

Since day one of HomePod's release and me buying/setting it up, both my Apple TV 4K and HomePod show as disconnected in the Home app and I have lost remote functionality. The day the HomePod came out, before I even opened or set up my HomePod, my Apple TV 4K began showing as "Apple TV not responding" in the Home app's status section on my iPhone and iPad. I signed out of iCloud and tried restarting my Apple TV, but still the same issue. The only thing now was that the "HomeKit - Connected" in the Apple TV's settings had disappeared altogether. So I decided to setup my HomePod, since that would take over as the main hub anyway, but no. It was fine for a minute and started showing as "No Response!" I could not alter the HomePod's settings or set alarms on it in the Home app either. I must have reset and re-added the HomePod over 5 times. I even tried waiting a few days to see if the issue would just resolve itself. I have fiber internet, 100 mb up and 100 mb down. I have an AirPort Time Capsule (latest model) as my main router and an AirPort Extreme (latest model) as an wifi extender. I have even removed my home, re-added everything. Signed out of iCloud on all devices and back in. Removed HomePod and re-added to my account. Even went out and returned/bought another HomePod to replicate the same issue. I tried restoring and setting up my Apple TV 4K without the HomePod connected to my account, and the "HomeKit - Connected" came back in the Apple TV's settings, but it was still showing in the Home app in the iPhone and iPad as "Apple TV not responding". Finally, I decided to make a brand new Apple ID and set up the HomePod and my iPad Pro on that Apple ID to see if I would get the same issue, and wouldn't you know it, the HomePod was working exactly as it's supposed to on that new Apple ID, which tells me this is clearly an issue with my original Apple ID or iCloud account and apple support has not been providing me any solid answers or feedback yet. Does anyone else have this issue and has anyone found a solution? Apple has been useless over the phone. I have been calling back and forth with advisors for over a month now and still no solution. Before February 9, my HomeKit setup was working flawlessly.

HomePod, iOS 11.2.6, Apple HomeKit

Posted on

Reply

Page content loaded

Mar 11, 2018 6:08 AM in response to krazygreekguy In response to krazygreekguy

Since you set the HomePod up on the new account and proved that it worked have you tried switching back to your original account? It isn't ideal, but you can use one account for iCloud and a different account for the iTunes and App stores. See the Manage Music & Podcasts section of Change settings for HomePod - Apple Support and tap the current account to change.


tt2

Mar 11, 2018 6:08 AM

Reply Helpful

Mar 11, 2018 10:32 PM in response to turingtest2 In response to turingtest2

Yes, I have and still no go. That is not ideal and I should not have to do that for all the money I have given Apple over the years. They need to take accountability and help their loyal users through all these glitches in their software. One of the reasons I am loyal to Apple is their attention to detail, but lately I feel like that has not been the case.

Mar 11, 2018 10:32 PM

Reply Helpful
User profile for user: krazygreekguy

Question: HomePod & Apple TV 4K HomeKit - Disconnected