Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: ipad2 update

How can I update past 5.1.1 ? I've tried downloading and installing 7, 9 and 10 but get a message that the firmware file isn't compatible.


User uploaded file

iPad 2 Wi-Fi, iOS 5.1.1

Posted on

Reply
Question marked as Solved
Answer:
Answer:

Are you certain you have an iPad 2? Does it have cameras?

Posted on

There’s more to the conversation

Read all replies

Page content loaded

Question marked as Helpful

Mar 10, 2018 6:11 PM in response to miztrniceguy In response to miztrniceguy

If you’re using an iPad 1, it can’t be updated past 5.1.1.

If you’re using an iPad 2, use its Software Update function or iTunes on a computer, and accept the firmware given instead of choosing a file manually.


(158573)

Mar 10, 2018 6:11 PM

Reply Helpful (1)
User profile for user: miztrniceguy

Question: ipad2 update