Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: iTunes videos with multiple audio tracks

I have videos in iTunes with multiple audio tracks, but Apple TV only shows the first one. How can I select a different audio track?

iMac (Retina 5K, 27-inch, 2017), macOS High Sierra (10.13.2)

Posted on

Reply
Question marked as Solved
Answer:
Answer:

It must have something to do with the encoding. I have , for example a rip of The Beatles+ with 3 audio tracks visible, all AC3 ( Stereo, DD 5.1 and another Stereo one )


Also check the audio setting on the Apple TV as to what it is spitting out and see if changing that enables some alternative audio tracks.

Posted on

Page content loaded

Mar 12, 2018 6:55 AM in response to turingtest2 In response to turingtest2

I know how to do that. On my iMac, I do see the list of the audio tracks and can change them and listen to any track on my iMac, but if I send to the Apple TV with Airplay, then the audio that plays through Airplay is only the first listed audio track, not the one that I selected.


If I try to change the audio track on the Apple TV, as described in the link you provided, I do not see any of the audio tracks listed. I see thee lists for Sound and for Speaker, but not for Languages. Actually all of the audio tracks are in English, but they have different content.


I tried checking and unchecking "Prefer AC3 Passthrough, but that made no difference.

Mar 12, 2018 6:55 AM

Reply Helpful
Question marked as Solved

Mar 12, 2018 7:14 AM in response to kingfisher500 In response to kingfisher500

It must have something to do with the encoding. I have , for example a rip of The Beatles+ with 3 audio tracks visible, all AC3 ( Stereo, DD 5.1 and another Stereo one )


Also check the audio setting on the Apple TV as to what it is spitting out and see if changing that enables some alternative audio tracks.

Mar 12, 2018 7:14 AM

Reply Helpful

Mar 12, 2018 7:25 AM in response to Airsculpture In response to Airsculpture

It appears to make no difference if all the tracks have the same encoding or not. Also, I have one video with an English audio Track and an Italian one. iTunes shows that the tracks are in those different languages, but Apple TV still does not show any Languages on the Audio Info screen.


I will look at the Apple TV settings, as you suggest.

Mar 12, 2018 7:25 AM

Reply Helpful

Mar 12, 2018 7:29 AM in response to kingfisher500 In response to kingfisher500

I'm afraid I don't have any content with multiple audio tracks, so I cannot run any experiments of my own. You could see if there is a pull down menu on the Apple TV that lets you select between the tracks. If this is an iTunes purchase can you play directly from the Apple TV with options rather than AirPlay it? Either way use Feedback - iTunes - Apple to let Apple know about your difficulties accessing the alternate audio.


tt2

Mar 12, 2018 7:29 AM

Reply Helpful

Mar 12, 2018 7:39 AM in response to Airsculpture In response to Airsculpture

In Apple TV Setting>Video and Audio>Surround Sound, I changed the setting from "Best Available" to "Dolby Digital 5.1."


Now all audio tracks are listed under Audio Info while the video is playing and I can choose and listen to any of them whether they are Surround 5.1, or Stereo.


Thanks for you help.

Mar 12, 2018 7:39 AM

Reply Helpful (1)

Mar 12, 2018 7:46 AM in response to turingtest2 In response to turingtest2

See my previous message for the solution to my problem. It works, but seems odd that I had to do this to make other audio tracks available.


I do play these videos directly from the Apple TV. The Airplay attempt was merely a test.

Mar 12, 2018 7:46 AM

Reply Helpful
User profile for user: kingfisher500

Question: iTunes videos with multiple audio tracks