Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: My factory update is taking so long why?

Hello, I have an iPad mini from 2012. Today, March 11,2018, I had trouble with multiple apps (they would shut down when I opened them). I went into my settings and did a whole factory reset. Before that I tried to hold down my power button but nothing happened. It is still stuck on the Apple logo. Please help!

Posted on

Reply

Page content loaded

Mar 13, 2018 5:54 PM in response to sarahfromambler In response to sarahfromambler

Hi sarahfromambler,

Thank you for using Apple Support Communities. It's my understanding that your iPad is stuck with an Apple logo after trying to restore to factory settings. Also, there's no change when holding down the power button. I can surely see how this could be concerning. I've got a resource that can get this issue resolved.

Please take a look at the link below. Follow the steps in the section "If your device turns on but gets stuck during start up".

If your iPhone, iPad, or iPod touch won't turn on or is frozen

Let us know the results. Please include specific error messages and any other troubleshooting steps you may have tried.

Have a great day!

Mar 13, 2018 5:54 PM

Reply Helpful
User profile for user: sarahfromambler

Question: My factory update is taking so long why?