Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: WD Passport Problems

I just purchased a 3TB WD Passport and when I plug in to my MacBook Air (Mac OS High Sierra) I get "The disk you inserted was not readable by this computer".

When I tap on "initialize" and "View all devices" I can see the "WD My Passport 25E2 Media" in bold as opposed to a volume "disk2s1" which is greyed out.

I've ran first aid on the "WD My Passport" and I get "First Aid found corruption that needs to be repaired. To repair the startup volume, run First Aid from Recovery".

I tried this (I think) and didn't get a different response.

I also tried (not really knowing what I'm doing) to partition the device with every format available and always get the same "operation failed: MediaKit reports not enough space on device for requested operation".

Again, I just bought this and just plugged it in.

Any help would be much appreciated. Cheers!

Posted on

Reply

Page content loaded

There are no replies.
User profile for user: gypsycreek

Question: WD Passport Problems