Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: I can't turn off calendar invites on a shared calendar on my Apple Watch

I have turned off notifications from the shared calendar already, and none of these invitations come through on my phone or MacBook Pro. The invitations on my Apple Watch persist.

Posted on

Reply

Page content loaded

Mar 15, 2018 1:48 PM in response to tindahbawks In response to tindahbawks

Hi there, tindahbawks,

Thanks for stopping by Apple Support Communities! From your post, I understand that you have disabled notifications for a particular calendar, and while that has worked on your Mac and iPhone, it does not appear to have been turned off on your Apple Watch. I'd be happy to help!

There could be a few things going on to cause your notifications to appear on your Apple Watch. I would recommend reviewing the information in Notifications on your Apple Watch - Apple Support , specifically the last two sections:

Customize or mirror your notification settings

By default, your Apple Watch notifications are set up to mirror your iPhone settings. For example, if you set your iPhone Mail app to notify you only of VIP emails and your watch notifications mirror your iPhone, you'll see only VIP email notifications on your Apple Watch.

For built-in apps, you can customize the notifications on your Apple Watch:

  1. Open the Apple Watch app on your iPhone.
  2. Tap the My Watch tab, then tap Notifications.
  3. Tap an app. If you want the app's notification settings to mirror settings on your iPhone, tap Mirror my iPhone. If you want to use different notification settings just for your Apple Watch, tap Custom.

For third-party apps, you can turn off notifications. Scroll down to the Mirror iPhone Alerts From section and turn off the setting next to the app.


User uploaded file

If you want to hide the notification icon

User uploaded file appears on your watch face when you get a notification. You can hide the red dot, so it doesn't appear when you have unread notifications:

  1. Open the Apple Watch app on your iPhone.
  2. Tap the My Watch tab, then tap Notifications.
  3. Turn off Notifications Indicator.



If you've gone through those steps to turn notifications off and still receive them, try restarting your Apple Watch ( How to restart your Apple Watch - Apple Support ) and your paired iPhone ( Restart your iPhone, iPad, or iPod touch - Apple Support ).

Have a great day.

Mar 15, 2018 1:48 PM

Reply Helpful
User profile for user: tindahbawks

Question: I can't turn off calendar invites on a shared calendar on my Apple Watch