Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Iphone 4 Software

I need to download apps onto my iphone, specifically Yahoo mail as it takes so much time to go through the security for online login (it has to email or text my mother and she has to send me the log in code from England, so obviously time difference creates major problems). However, when I try to download the apps onto my iphone it says I have to have IOS 10 to be able to download the app. BUT YET, I cant update the software on my iphone, so it's a continuous circle of not being able to do ANYTHING.

iPhone 4, iOS 7.1.2

Posted on

Reply

Page content loaded

Mar 13, 2018 1:11 PM in response to lizzieallday In response to lizzieallday

Hello lizzieallday,

I understand that you have an iPhone 4 running iOS 7.1.2 and you are wanting to know how to update to iOS 10 or later in order to install apps. I'll be happy to provide some insight on this. As it turns out, you are running the highest iOS version that is compatible with the iPhone 4. In order to run iOS 10 you would need:

Download iOS 10.0 - iOS 10.3.3 Information​

System Requirements
iPhone 5 or newer
iPad 4th generation or newer
iPad mini 2 or newer
iPod touch (6th generation)
Available via OTA and iTunes



Thanks for asking your question in the Apple Support Communities.

Take care.

Mar 13, 2018 1:11 PM

Reply Helpful
User profile for user: lizzieallday

Question: Iphone 4 Software