Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: IMPORTING MY OWN CD'S TO ITUNES MY LIBRARY

I have started to import my own CD's into iTunes - My Library, and many of them then appear in iTunes in My Albums looking like the original CD with the tracks listed in the same order as on the CD. However, when I import a CD, such as Sunset Blvd. the imported Album finishes up as 6 or 7 separate albums in iTunes, and makes it difficult to listen to the tracks in the correct sequence. It seems to be grouping them by the Artist.

Is this a common problem or should I be doing something different.

iMac (27-inch Mid 2011)

Posted on

Reply
Question marked as Solved
Answer:
Answer:

If you see unexpected groups of songs when you browse an album - https://support.apple.com/HT204538 - "Songs from the same album might not be grouped together as you expect when you view them in the Albums view in iTunes."


For most people this solution seems to be the one that works: Aug. 2008 post by turingtest2 about temporarily changing labels - https://discussions.apple.com/message/7904806#7904806 or http://www.samsoft.org.uk/iTunes/merge.asp - Add a letter at the end of the artist name, close the Get Info window, then open it again and remove the letter. This often works but I have had cases where tracks grouped when a letter was added but ungrouped when it was removed again.


The next sections provide additional solutions:


Often a solution: Select all the tracks on the album, File > get info (or right-click > get info > details), and either give them all a single "album artist", or check the "compilation" flag (as in https://discussions.apple.com/message/17670085#17670085).


Steve MacGuire a.k.a. turingtest2 - iTunes & iPod Hints & Tips - Grouping Tracks Into Albums - http://www.samsoft.org.uk/iTunes/grouping.asp (older post on Apple Discussions http://discussions.apple.com/message/9910895#9910895)


If these are from multiple-CD sets you may also need to enter the appropriate information in the disc number fields. If they are not a multiple CD set you still need to make sure the disc number fields are set correctly or all empty.


Another explanation by hhgttg27 August 2015 - https://discussions.apple.com/message/27784417#27784417


If they are mp3 files try changing the ID3 tag version which may cause iTunes to re-write the tags and clear up inconsistencies. I use iTunes 7.5 (yes, from 2007) so I can't tell you where this is in later versions.


I had one case of really stubborn grouping. The tracks would re-group in ways that didn't make sense when I changed metadata. Without going into detail, I deleted the tracks completely from iTunes, then re-added the files and they all grouped correctly. Doing this will result in some metadata loss but if you have no choice...

Posted on

There’s more to the conversation

Read all replies

Page content loaded

Question marked as Solved

Mar 13, 2018 8:58 AM in response to Len Bradshaw In response to Len Bradshaw

If you see unexpected groups of songs when you browse an album - https://support.apple.com/HT204538 - "Songs from the same album might not be grouped together as you expect when you view them in the Albums view in iTunes."


For most people this solution seems to be the one that works: Aug. 2008 post by turingtest2 about temporarily changing labels - https://discussions.apple.com/message/7904806#7904806 or http://www.samsoft.org.uk/iTunes/merge.asp - Add a letter at the end of the artist name, close the Get Info window, then open it again and remove the letter. This often works but I have had cases where tracks grouped when a letter was added but ungrouped when it was removed again.


The next sections provide additional solutions:


Often a solution: Select all the tracks on the album, File > get info (or right-click > get info > details), and either give them all a single "album artist", or check the "compilation" flag (as in https://discussions.apple.com/message/17670085#17670085).


Steve MacGuire a.k.a. turingtest2 - iTunes & iPod Hints & Tips - Grouping Tracks Into Albums - http://www.samsoft.org.uk/iTunes/grouping.asp (older post on Apple Discussions http://discussions.apple.com/message/9910895#9910895)


If these are from multiple-CD sets you may also need to enter the appropriate information in the disc number fields. If they are not a multiple CD set you still need to make sure the disc number fields are set correctly or all empty.


Another explanation by hhgttg27 August 2015 - https://discussions.apple.com/message/27784417#27784417


If they are mp3 files try changing the ID3 tag version which may cause iTunes to re-write the tags and clear up inconsistencies. I use iTunes 7.5 (yes, from 2007) so I can't tell you where this is in later versions.


I had one case of really stubborn grouping. The tracks would re-group in ways that didn't make sense when I changed metadata. Without going into detail, I deleted the tracks completely from iTunes, then re-added the files and they all grouped correctly. Doing this will result in some metadata loss but if you have no choice...

Mar 13, 2018 8:58 AM

Reply Helpful (1)
Question marked as Helpful

Mar 13, 2018 8:59 AM in response to Len Bradshaw In response to Len Bradshaw

Generally it is enough to set a common Album Artist and Album title for all tracks that are from the same album. See Grouping tracks into albums for deeper problems.


tt2

Mar 13, 2018 8:59 AM

Reply Helpful (1)

Mar 13, 2018 8:59 AM in response to Limnos In response to Limnos

Hi Limnos Many thanks for your quick response. I have copied all these comments and links to my help files and the hint that works for me is by going into Songs and selecting all the tracks on the same Album and then editing the song info to ensure compilation flag is ticked. This worked for me and my Sunset Boulevard (2 x CD set) now show up in iTunes, My library as 2 separate Albums with all the tracks in the correct sequence.

Mar 13, 2018 8:59 AM

Reply Helpful

Mar 13, 2018 9:03 AM in response to turingtest2 In response to turingtest2

Please see my post below to Limnos. Many thanks for your assistance and advice. I did not have to make the changes you suggested because the simple act of ensuring the Compilation flag was ticked solved my problem. I have kept your recommendation on file should I need further help in this matter in the future.

Mar 13, 2018 9:03 AM

Reply Helpful
User profile for user: Len Bradshaw

Question: IMPORTING MY OWN CD'S TO ITUNES MY LIBRARY