Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: HomeKit Scene Failed

I had never had a problem with my any of my HomeKit scenes working until just the last couple weeks or so. It only seems to be one scene that I’m having a problem with.

The scenes in question seem to be:


Goodnight:

Turns off the Lutron Caseta dimmer switch (lights)

Turns off 7 Philips Hue lights

Turns on iDevices plug in outlet for box fan

Turns off 2 iDevices nightlights

Locks August Smart Lock (this is the regular August Smart Lock from before the Smart Lock Pro)


If I try to activate this scene via Siri she just tells me, “Your secure scene is still in progress. To confirm, ask me about your secure devices again in a few moments.” And nothing is triggered (including the lock). The strange thing is that I have additional scenes that trigger the lock and there are no problems. If I remove the lock from the scene it still fails, and if I try to trigger it through Siri without the lock she says, “Setting your scene with HomeKit...” But nothing happens.

Now what’s really strange to me if that if I open the scene in the Home app, check the details, and select “Test This Scene” everything works perfect including the door locking. I have no idea what’s going on, there seems to be no consistency here. Again, it’s only one scene working and I’ve tried removing devices that aren’t in other scenes and it still refuses to trigger, I’ve tried deleting the scene and re-adding it and nothing seems to work.

Anyone else having an issue like this? Anyone able to off help, please?


Additionally, this happens whether I attempt through the app or via Siri on my or my wife’s iPhone 6s, my iPad Pro 10.5, my HomePod, my Apple TV 4th gen, my Apple Watch, or my wife’s iPad Mini 3.

HomePod, iOS 11.2.6

Posted on

Reply

Page content loaded

Mar 29, 2018 4:54 PM in response to morethanseth In response to morethanseth

I just started getting that message too when saying “Hey Siri, Good Night,” except my scene does get completed. I have it turn all 11 light switches off, 5 outlet switches off, and close the garage door.

Mar 29, 2018 4:54 PM

Reply Helpful

Apr 2, 2018 10:11 PM in response to morethanseth In response to morethanseth

I have the goodnight scene turning 4 hue lights OFF, 2 hue lights ON, 2 iHome outlets off, closing a Chamberlain garage door and locking two Schlage Sense deadbolts.


I’m experiencing this issue on both my iPhone and HomePod when interacting with Siri

. If I remove the 3 secured devices (garage door and deadbolts), it works reliably. It works (secure devices included) if I manually set the scene in the Home app, albeit with a very slight pause when the progress circle hits the 9 o’clock position. I wonder if it has to do with Siri possibly having a more stringent “reply” timeout.


Regardless, something is wrong and needs to be tweaked/fixed.

Apr 2, 2018 10:11 PM

Reply Helpful

May 24, 2018 4:38 AM in response to morethanseth In response to morethanseth

I seem to be having the same problem.


My Goodnight scene closes my Chamberlain garage doors and it's no longer working. Not exactly sure when the problem started because the scene only kicks in via a schedule in case my kids leave a door open late at night.


When I try to control the accessory (garage door) from the Apple Home app, I get "no response" error. But the Chamberlain app works fine - I can open and close the doors with it


-- Never mind. I fixed it.

May 24, 2018 4:38 AM

Reply Helpful

May 25, 2018 8:57 PM in response to morethanseth In response to morethanseth

I have the same issue and im almost sure it’s the lock. If you remove the lock from your scene the scene runs normally. In the past the HomePod would wait for the answer of the lock, now it seems to be to fast and replies before the locks is done sending the final state.

May 25, 2018 8:57 PM

Reply Helpful (1)

May 29, 2018 9:29 PM in response to morethanseth In response to morethanseth

This is happening to me as well. Yale Asure Locks and Chamberlain garage door. When I use them seperate it is fine. When I add either of the 3 secure devices it won’t work and gives me the error. At least I know this isn’t a Yale issue.

Today 11.4 is out and I was hoping it would be fixed but no such luck. If anyone finds an answer please post.

May 29, 2018 9:29 PM

Reply Helpful

Jun 6, 2018 8:02 AM in response to pfhrtc0 In response to pfhrtc0

Actually, my fix (rebooting the Chamberlain myQ bridge) only lasted for 1 day. I'll still having the problem.

Jun 6, 2018 8:02 AM

Reply Helpful
User profile for user: morethanseth

Question: HomeKit Scene Failed