Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: I can't install tar.gz

I can not install any tar.gz files downloaded from GitHub I was trying to install this one particularly :-https://github.com/gbrown5/InputRedirectionClient-Qt/releases/tag/3.0

because the mac os version is outdated,

but when I try to use the "./configure" it says No such file or directory and I have done the cd command to navigate to the extracted directory


Help would be appreciated

MacBook Pro, macOS High Sierra (10.13.3), Xcode command line tools installed

Posted on

Reply
Question marked as Solved
Answer:
Answer:

what version(s) does it say it supports?

what version would you prefer?


Unless you are already a developer with deep knowledge of MacOS internals, converting this for use with a different version of MacOS is likely to be VERY complex. You should ask the guy who posted it on GitHub whether he can support your version of MacOS.

Posted on

Page content loaded

Mar 14, 2018 8:02 AM in response to shashwatfrommohali In response to shashwatfrommohali

InputRedirectionExtendedOsx.zip unzips into an Application named InputRedirectionClient-Qt.app


No Installer is required or included. If the author is not an Apple registered developer, you will need to bypass GateKeeper to get this .app to run. Post back for details about how to do that if you need to.


The only tar.gz is the source code. Did you want to re-complie the source code?

Mar 14, 2018 8:02 AM

Reply Helpful

Mar 14, 2018 8:34 AM in response to Grant Bennet-Alder In response to Grant Bennet-Alder

Yes I tried to unzip it using archive utility but it does not work the app extracted is not compatible with my MacBook so i thought of compiling a version myself so its compatible with my particular Mac

Mar 14, 2018 8:34 AM

Reply Helpful
Question marked as Solved

Mar 14, 2018 10:17 AM in response to shashwatfrommohali In response to shashwatfrommohali

what version(s) does it say it supports?

what version would you prefer?


Unless you are already a developer with deep knowledge of MacOS internals, converting this for use with a different version of MacOS is likely to be VERY complex. You should ask the guy who posted it on GitHub whether he can support your version of MacOS.

Mar 14, 2018 10:17 AM

Reply Helpful
User profile for user: shashwatfrommohali

Question: I can't install tar.gz