Related Article

If you can't send or receive messages on your iPhone, iPad, or iPod touch

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.


Question: Question???

I have my icloud signed into my macbook how do I stop my messages from going to my macbook?

Posted on


Page content loaded

Mar 14, 2018 4:20 PM in response to gervell In response to gervell

What does "messages" mean exactly? There are two very different types of messages the iPhone deals with.

  • iMessages? Use the Messages' application menu on the Mac to go to Messages > Preferences > Accounts > [Your iCloud Account] and uncheck "Enable this account".
  • SMS cellular text messages? On the iPhone, go to Settings > Messages > Text Message Forwarding and turn the Mac "Off".

Mar 14, 2018 4:20 PM

Reply Helpful
User profile for user: gervell

Question: Question???