Announcement: Upgrade to macOS Mojave

With features like Dark Mode, Stacks, and four new built-in apps, macOS Mojave helps you get more out of every click. 
Find out how to upgrade to macOS Mojave > https://support.apple.com/macos/mojave

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Fix for "On My Mac" calendars not available when using iCloud

I researched this one for a while and found all kinds of answers (even from Apple) that did not work so I decided to post how I fixed it.


Problem: Cannot add an "Open file" alert in a calendar event. Adding the alert gets automatically deleted after applying the setting.


The root cause was that I tried adding the Alert to an iCloud calendar, which, as I found out, doesn't work. (Apple, you should just not allow us to select the option in that case).


The proposed fix was to add an "On My Mac" Calendar, but every time I tried, the calendar would get automatically created in iCloud. If I disabled iCloud, it would add the calendar properly but would convert it to an iCloud calendar as soon as I logged back in.


The Fix!!!!
1. Unselect all of your iCloud Calendars:

User uploaded file

2. Right click on the white space below all of your calendars and select New Calendar

User uploaded file

3. An Untitled calendar shows up at the top in an added section called On My Mac

User uploaded file


4. Add all of your iCloud calendars checkmark back in and you are good to go.

User uploaded file


You can now add an event in your new On My Mac calendar and schedule an alert to open a file, and in my case, have it repeated daily.


I hope this was useful!


User uploaded file

User uploaded file

User uploaded file

iMac Intel 2.16Ghz, Mac OS X (10.6.1)

Posted on

Reply

Page content loaded

Mar 15, 2018 10:57 PM in response to Wisefrog In response to Wisefrog

You wrote - The proposed fix was to add an "On My Mac" Calendar, but every time I tried, the calendar would get automatically created in iCloud. If I disabled iCloud, it would add the calendar properly but would convert it to an iCloud calendar as soon as I logged back in. in your case you are using only iCloud account thats the reason the setting goes to default .


The correct method is open calendar and its preferences in alerts click on drop down arrows of account and select on my Mac .

User uploaded file

Take cursor on top menu bar > file > click on new calendar it will be created under on my Mac section and saved .

User uploaded file

But as soon as you close calendar preferences and quit calendar application the settings goes to default as if the user has created an Apple ID same as gmail address and signed in with Apple ID in iCloud account .

User uploaded file

See this help -


User uploaded file

Mar 15, 2018 10:57 PM

Reply Helpful

Mar 16, 2018 5:36 AM in response to Luis Sequeira1 In response to Luis Sequeira1

Thank you for your reply. Unfortunately, that arrow next to New Calendar only seems to appear if you already have an On My Mac calendar.


To test this, I deleted the two On My Mac calendars I had (only had one event in each so it wasn't a big deal), and as you can see in the screenshot, the arrow pointing to the submenu disapeared.

User uploaded file


However, I did found out that you do not need to unselect your iCloud accounts to add one, you just need to make sure that any other type of calendar (if you have any) need to be selected before right-clicking in the white space and adding a new calendar.


Once an On My Mac calendar is created, the arrow in File/New Calendar appears for future calendar creation.

User uploaded file

Mar 16, 2018 5:36 AM

Reply Helpful (1)

Mar 16, 2018 5:46 AM in response to Wisefrog In response to Wisefrog

Wisefrog wrote:


Thank you for your reply. Unfortunately, that arrow next to New Calendar only seems to appear if you already have an On My Mac calendar.


To test this, I deleted the two On My Mac calendars I had (only had one event in each so it wasn't a big deal), and as you can see in the screenshot, the arrow pointing to the submenu disapeared.

FWIW, that doesn't quite make sense since you had two "On My Mac" calendars to delete. So what Luis and I posted should have worked before you deleted them.

Mar 16, 2018 5:46 AM

Reply Helpful

Mar 16, 2018 5:52 AM in response to dialabrain In response to dialabrain

dialabrain wrote:


Wisefrog wrote:


Thank you for your reply. Unfortunately, that arrow next to New Calendar only seems to appear if you already have an On My Mac calendar.


To test this, I deleted the two On My Mac calendars I had (only had one event in each so it wasn't a big deal), and as you can see in the screenshot, the arrow pointing to the submenu disapeared.

FWIW, that doesn't quite make sense since you had two "On My Mac" calendars to delete. So what Luis and I posted should have worked before you deleted them.


If you go back to my original story, I did not have any "On My Mac" accounts when all of this started. My reply was to say that your proposed solution only works if you already have an On My Mac account.


If the screen shots I just provided are not sufficient, you are welcome to try it on your Mac.


Regards,

Mar 16, 2018 5:52 AM

Reply Helpful
User profile for user: Wisefrog

Question: Fix for "On My Mac" calendars not available when using iCloud