Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: My iMessages aren’t going through as my phone number.

My iMessages are going through as my email and not my phone number.

Posted on

Reply

Page content loaded

Mar 16, 2018 8:20 AM in response to emilyfromcorydon In response to emilyfromcorydon

Hello emilyfromcorydon,


Thanks for that info and choosing the Apple Support Communities. If I understand correctly, you are unable to use your phone number in the Messages app on your iPhone. To help with this issue, please follow these steps from this Apple resource on your situation:

Set up your phone number

These steps work only with the phone number that belongs to your iPhone, not the phone number of a landline or other device. On your iPhone:

  1. Go to Settings > Messages and make sure that iMessage is on. You might need to wait a moment for it to activate.
  2. Tap Send & Receive. If you see “Use your Apple ID for iMessage,” tap it and sign in with the same Apple ID that you use on your Mac, iPad, and iPod touch.
    User uploaded file
  3. In the “You can be reached” section, make sure that there are checkmarks beside your phone number and Apple ID.
  4. Go to Settings > FaceTime and follow the same steps.

If you can't see or select your number in Messages or FaceTime

  1. Make sure that you're using the latest software for your Mac or iOS device.
  2. Make sure that you correctly followed the iPhone steps to set up your phone number. You should be using the same Apple ID on all of your devices.
  3. In the “You can be reached” section of Messages and FaceTime settings, make sure that there are checkmarks beside your phone number and Apple ID:
    User uploaded file

If your phone number is unchecked and you can't select it, or you have some other issue, follow these steps:

  1. On your Mac:
    • In Messages, choose Messages > Preferences, then click Accounts and select your iMessage account. Click Sign Out.
    • In FaceTime, choose FaceTime > Preferences, then click Sign Out.
  2. On your iPhone, iPad, and iPod:
    • Go to Settings > Messages > Send & Receive. Tap your Apple ID, then tap Sign Out.
    • Go to Settings > FaceTime. Tap your Apple ID, then tap Sign Out.
  3. On your iPhone:
    • Go back to Settings > Messages and make sure that iMessage is turned on.
    • Tap Send & Receive, then choose “Use your Apple ID for iMessage” and sign in with your Apple ID.
  4. Using the same Apple ID, sign back in to Messages and FaceTime on your other devices.

If you still need help, change your Apple ID password and repeat the setup steps. If that doesn't work, contact Apple Support.


Add or remove your phone number in Messages or FaceTime - Apple Support


Cheers!

Mar 16, 2018 8:20 AM

Reply Helpful
User profile for user: emilyfromcorydon

Question: My iMessages aren’t going through as my phone number.