Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Some PNGs render black in Safari

Has anyone seen a problem in which PNG images render totally black in Safari?


For me this happens on only one of my three Macs, only in Safari, and then only with some PNGs. So it's not related solely to my setup, nor solely to the PNGs I'm viewing. It must be some combination of the two.


I don't think this is the same as the PDF black screen problem. I've been there, and fixed it by calibrating my monitor. But that hasn't cured the PNG problem, which I believe is relatively new (within the last two or three months).


My three Macs are a 2009 Mac mini, a 2011 Mac mini and a 2015 MBP. All are running macOS 10.13.3 (yes, even the 2009 Mac mini). The 2011 Mac mini is the only one on which I've been able to reproduce the problem.


My test images are at https://stanhoe.org/history/maps/1905-map and the larger lightbox version that displays when you click on the map. On the Mac mini 2011 in Safari these consistently show as black, whether I view them on the website or download them first. Occasionally I see the correct graphic for perhaps a tenth of a second, and then it goes black (the PDF bug gave the same behaviour, almost as if the image is there but is overlaid by a black mask).


On the same machine those same images display fine in Preview, Chrome and Firefox. They are also fine in Safari on the other two Macs (and my iPhone).


I have 6 Safari extensions (1Password, Adblock Plus, DEVONthink, Shortly, Pocket, Translate). Disabling them makes no difference, and besides I run the same combination on the MBP with no problems.


On the same website (mine) is another pair of PNGs at https://stanhoe.org/history/maps/1639-map. They give the same results. The other maps in that section are JPGs, so they work OK. I probably prepared the PNGs with ImageAlpha, so it may be that this app created PNGs that are unusual in some way. But that doesn't really explain why they display OK in other apps and in Safari on other Macs.


Any ideas on how to troubleshoot further will be very welcome.


Charles

Mac mini, macOS High Sierra (10.13.3)

Posted on

Reply

Page content loaded

Mar 16, 2018 9:50 AM in response to Charles Butcher In response to Charles Butcher

Try setting up another admin user account to see if the same problem continues. If Back-to-My Mac is selected in System Preferences, the Guest account will not work. The intent is to see if it is specific to one account or a system wide problem. This account can be deleted later. Please post if this worked or not.


Isolating an issue by using another user account


If the problem is still there, try booting into the Safe Mode using your normal account. Disconnect all peripherals except those needed for the test. Shut down the computer and then power it back up after waiting 10 seconds. Immediately after hearing the startup chime, hold down the shift key and continue to hold it until the gray Apple icon and a progress bar appear. The boot up is significantly slower than normal. This will reset some caches, forces a directory check, and disables all startup and login items, among other things. When you reboot normally, the initial reboot may be slower than normal. If the system operates normally, there may be 3rd party applications which are causing a problem. Try deleting/disabling the third party applications after a restart by using the application un-installer or by using the developer’s uninstall instructions. For each disable/delete, you will need to restart if you don't do them all at once. Please post if this worked or not.





Safe Mode - About El Capitan
also Sierra


Safe Mode Startup – El Capitan. also Sierra


If it works in the Safe Mode, try running this program when booted normally and then copy and paste the output in a reply. The program was created by Etresoft, a frequent contributor. Please use copy and paste as screen shots can be hard to read. Click “Share Report” button in the toolbar, select “Copy to Clipboard” and then paste into a reply. This will show what is running on your computer. No personal information is shown. You can run the report for free at least once, but if you run it several times, at some point it will ask you to pay a license fee.

Etrecheck – System Information

Mar 16, 2018 9:50 AM

Reply Helpful

Mar 16, 2018 3:30 PM in response to Eric Root In response to Eric Root

Thank you Eric. A clean admin account didn't fix the problem, but safe mode seems to. EtreCheck report below. Any suggestions short of uninstalling everything? Disabling Safari extensions doesn't help, and nor does turning off Little Snitch (though I suppose the kernel extension remains in place?)


I have Rogue Amoeba's excellent Piezo installed with the "instant record" function, and recently saw someone fingering that as a cause of system problems.


Charles


EtreCheck version: 4.1.3 (4A188)

Report generated: 2018-03-16 22:12:17

Download EtreCheck from https://etrecheck.com

Runtime: 4:42

Performance: Good


Problem: Other problem

Description:

Some PNG files display as black in Safari, although they are fine in Preview, Firefox and Chrome.


Major Issues: None


Minor Issues:

These issues do not need immediate attention but they may indicate future problems.


Unsigned files - There is unsigned software installed. They appear to be legitimate but should be reviewed.

System modifications - There are a large number of system modifications running in the background.

Vintage hardware - This machine may be considered vintage.

32-bit Apps - This machine has 32-bits apps that may have problems in the future.


Hardware Information:

Mac mini (Mid 2011) - Vintage!

Mac mini Model: Macmini5,1

1 2.3 GHz Intel Core i5 (i5-2415M) CPU: 2-core

8 GB RAM At maximum

BANK 0/DIMM0

4 GB DDR3 1333 ok

BANK 1/DIMM0

4 GB DDR3 1333 ok


Video Information:

Intel HD Graphics 3000 - VRAM: 512 MB

S24F350 1920 x 1080 @ 60 Hz


Drives:

disk0 - Samsung SSD 850 EVO 250GB 250.06 GB (Solid State - TRIM: Yes)

Internal SATA 6 Gigabit Serial ATA

disk0s1 - EFI (MS-DOS FAT32) [EFI] 210 MB

disk0s2 249.85 GB

disk2s1 - f**t (APFS) 249.85 GB 143.06 GB

disk2s2 - Preboot (APFS) [APFS Preboot] 249.85 GB 41 MB

disk2s3 - Recovery (APFS) [Recovery] 249.85 GB 1.02 GB

disk2s4 - VM (APFS) [APFS VM] 249.85 GB 20 KB


disk1 - WDC WD10JPCX-24UE4T0 1.00 TB (Mechanical)

Internal SATA 6 Gigabit Serial ATA

disk1s1 - EFI (MS-DOS FAT32) [EFI] 210 MB

disk1s2 - s**e (Journaled HFS+) 750.00 GB

disk1s3 - big (Journaled HFS+) 249.73 GB


Mounted Volumes:

disk1s2 - s**e 750.00 GB (17.99 GB free)

Journaled HFS+

Mount point: /Volumes/s**e


disk1s3 - big 249.73 GB (139.05 GB free)

Journaled HFS+

Mount point: /Volumes/big


disk2s1 - f**t 249.85 GB (105.61 GB free)

APFS

Mount point: /


disk2s4 - VM [APFS VM] 249.85 GB (105.61 GB free)

APFS

Mount point: /private/var/vm


Network:

Interface en0: Ethernet

Interface en4: iPhone

Interface fw0: FireWire

Interface en1: Wi-Fi

802.11 a/b/g/n

One IPv4 address

Interface en3: Bluetooth PAN

Interface bridge0: Thunderbolt Bridge

iCloud Quota: 19.18 GB available


System Software:

macOS High Sierra 10.13.3 (17D102)

Time since boot: About an hour

System Load: 2.61 (1 min ago) 9.39 (5 min ago) 8.12 (15 min ago)


Security:

System Status
Gatekeeper Mac App Store and identified developers
System Integrity Protection Enabled


Unsigned Files:

Launchd: /Library/LaunchAgents/org.gpgtools.gpgmail.patch-uuid-user.plist

Executable: /Library/Application Support/GPGTools/uuid-patcher

Details: Exact match found in the whitelist - probably OK

Launchd: /Library/LaunchAgents/org.gpgtools.macgpg2.shutdown-gpg-agent.plist

Executable: /usr/local/MacGPG2/libexec/shutdown-gpg-agent

Details: Exact match found in the whitelist - probably OK

Launchd: /Library/LaunchAgents/org.gpgtools.macgpg2.fix.plist

Executable: /usr/local/MacGPG2/libexec/fixGpgHome

Details: Exact match found in the whitelist - probably OK

Launchd: /Library/LaunchDaemons/org.gpgtools.gpgmail.patch-uuid.plist

Executable: /Library/Application Support/GPGTools/uuid-patcher

Details: Exact match found in the whitelist - probably OK

Launchd: /Library/LaunchAgents/org.gpgtools.gpgmail.enable-bundles.plist

Executable: /Library/Application Support/GPGTools/uuid-patcher enable-bundles

Details: Exact match found in the whitelist - probably OK

Launchd: /Library/LaunchAgents/com.brother.LOGINserver.plist

Executable: /Library/Printers/Brother/Utilities/Server/LOGINserver.app/Contents/MacOS/LOGIN server

Details: Exact match found in the whitelist - probably OK


32-bit Applications:

Name Version
Clarify 2.0.10
DVD Player 5.8
Levelator 2.1.2
InkServer 10.9
extract text from PDFs 1.0
WakeUp 1.3
NETserver 1.1.9
docx unzip to desktop 1.0
LOGINserver 1.2.0
ColorSchemer Studio 2 2.0.1
MediaHuman Audio Converter 1.8.9
MathType 6.7h 14111000
extract annotations from a PDF 1.0
Audio Recorder 3.2
CalcService.service 3.4
LineIn 2.3.0
DFX
DeDRM 5 5.1
300 ppi CMYK 1.0
quicklookd32 5.0
createGcApp
SiteSucker 2.2.3
Snapz Pro X Uninstaller 2.2.0
PhotoZoom Pro 3 3.0.4
WireTap Pro Uninstaller 1.2
RegExRX 1.8.1
copy path
PhotoRescue 3.1.9
USBserver 1.2.0
Download URL List
Expression Media 2 2.0.2
Excalibur 4.0.7
delete DEVONtech storage files
Uninstall MathType 1.0
RemoteSetup 3.3.9
make HTML entities
ControlCenter 2.17.5


Kernel Extensions:

/Applications/Shimo.app

[Not Loaded] shimoNetworkTrigger.kext (Fabian Jaeger, 1.0 - SDK 10.12)

[Not Loaded] tap.kext (Fabian Jaeger, 20150118)

[Not Loaded] tun.kext (Fabian Jaeger, 20150118)

/Library/Extensions

[Loaded] LittleSnitch.kext (Objective Development Software GmbH, 4.0.5 - SDK 10.11)


System Launch Agents:

[Not Loaded] 9 Apple tasks
[Loaded] 169 Apple tasks
[Running] 112 Apple tasks


System Launch Daemons:

[Not Loaded] 36 Apple tasks
[Loaded] 182 Apple tasks
[Running] 113 Apple tasks


Launch Agents:

[Loaded] org.gpgtools.gpgmail.patch-uuid-user.plist (? 84ce07f2 - installed 2017-06-19)
[Loaded] org.gpgtools.Libmacgpg.xpc.plist (Lukas Pitschl - installed 2017-12-15)
[Running] org.gpgtools.macgpg2.shutdown-gpg-agent.plist (? df7bd0cf - installed 2017-12-20)
[Running] at.obdev.LittleSnitchUIAgent.plist (Objective Development Software GmbH - installed 2018-01-19)
[Running] at.obdev.LittleSnitchHelper.plist (Objective Development Software GmbH - installed 2018-01-19)
[Loaded] com.microsoft.update.agent.plist (Microsoft Corporation - installed 2018-01-24)
[Loaded] org.gpgtools.gpgmail.enable-bundles.plist (? d032aea - installed 2017-06-19)
[Other] com.adobe.ARMDCHelper.cc24aef4a1b90ed56a725c38014c95072f92651fb65e1bf9c8e43c37a2 3d420d.plist (Adobe Systems, Inc. - installed 2018-02-13)
[Running] com.brother.LOGINserver.plist (? a1772de2 - installed 2016-10-17)
[Loaded] org.gpgtools.macgpg2.fix.plist (? d7ac5146 - installed 2017-12-20)
[Loaded] org.gpgtools.updater.plist (Lukas Pitschl - installed 2018-02-10)


Launch Daemons:

[Loaded] com.adobe.ARMDC.SMJobBlessHelper.plist (Adobe Systems, Inc. - installed 2018-02-13)
[Loaded] org.gpgtools.gpgmail.patch-uuid.plist (? 42fc83f8 - installed 2017-06-19)
[Running] com.tunnelbear.mac.tbeard.plist (TunnelBear, Inc. - installed 2018-01-02)
[Loaded] com.microsoft.autoupdate.helper.plist (Microsoft Corporation - installed 2018-01-24)
[Running] com.bombich.ccchelper.plist (Bombich Software, Inc. - installed 2018-03-08)
[Loaded] com.bjango.istatmenus.installerhelper.plist (Bjango Pty Ltd - installed 2017-12-29)
[Running] at.obdev.littlesnitchd.plist (Objective Development Software GmbH - installed 2018-01-19)
[Not Loaded] org.eyebeam.SelfControl.plist (Charlie Stigler - installed 2017-12-30)
[Loaded] com.barebones.authd.plist (Bare Bones Software, Inc. - installed 2018-02-09)
[Loaded] com.adobe.ARMDC.Communicator.plist (Adobe Systems, Inc. - installed 2018-02-13)
[Loaded] com.cocoatech.pathfinder.SMFHelper7.plist (Dragan Milic - installed 2018-03-07)
[Loaded] com.microsoft.office.licensingV2.helper.plist (Microsoft Corporation - installed 2017-12-05)
[Loaded] com.rogueamoeba.instanton-agent.plist (Rogue Amoeba Software, LLC - installed 2018-01-16)
[Running] com.bjango.istatmenus.daemon.plist (Bjango Pty Ltd - installed 2018-03-01)
[Loaded] com.feingeist.shimo.helper.plist (Fabian Jaeger - installed 2018-01-02)


User Launch Agents:

[Running] com.spotify.webhelper.plist (Spotify - installed 2017-12-14)
[Loaded] com.google.keystone.agent.plist (Google, Inc. - installed 2018-02-04)
[Running] com.bjango.istatmenus.agent.plist (Bjango Pty Ltd - installed 2018-03-01)
[Loaded] com.dropbox.DropboxMacUpdate.agent.plist (Dropbox, Inc. - installed 2018-02-02)
[Running] com.tunnelbear.mac.tbeara.plist (TunnelBear, Inc. - installed 2018-02-20)
[Running] com.bjango.istatmenus.status.plist (Bjango Pty Ltd - installed 2018-03-01)


User Login Items:

Things Helper Application (Cultured Code GmbH & Co. KG

(~/Library/Application Support/Things Sandbox Helper/ThingsMacSandboxHelper.app)

TextExpander Application

(/Applications/TextExpander.app)

QuickCursor Application

(/Applications/QuickCursor.app)

DEVONthink Sorter Application (DEVONtechnologies, LLC

(/Applications/DEVONthink Pro.app/Contents/PlugIns/SorterPlugin.bundle/Contents/MacOS/DEVONthink Sorter.app)

HazelHelper Application (Noodlesoft, LLC

(~/Library/PreferencePanes/Hazel.prefPane/Contents/MacOS/HazelHelper.app)

Dropbox Application (Dropbox, Inc.

(/Applications/Dropbox.app)

Path Finder Application

(/Applications/Path Finder.app)

CCC User Agent Application (Bombich Software, Inc. - installed 2018-03-08)

(/Applications/Carbon Copy Cloner.app/Contents/Library/LoginItems/CCC User Agent.app)

Default Folder X Application (St. Clair Software

(/Applications/Default Folder X.app)

pomodoro Application

(/Applications/pomodoro.app)

Brightness Slider Application (Mac App Store

(/Applications/Brightness Slider.app)

Faviconographer Application (Thomas Osthege und Daniel Alm

(/Applications/Faviconographer.app)

iTunesHelper Application (Apple, Inc. - installed 2018-01-24)

(/Applications/iTunes.app/Contents/MacOS/iTunesHelper.app)

LaunchBar Application

(/Applications/LaunchBar.app)

Spotify Notifications Application (Mihir Singh

(/Applications/Spotify Notifications.app)

MailTagsHelper Application (Scott Morrison

(~/Library/Application Support/Indev/MailTagsHelper.app)

Itsycal Application (Sanjay Madan

(/Applications/Itsycal.app)

TunnelBear Application (TunnelBear, Inc.

(/Applications/TunnelBear.app)

BSLoginLauncher SMLoginItem (Mac App Store - installed 2017-12-29)

(/Applications/Brightness Slider.app/Contents/Library/LoginItems/BSLoginLauncher.app)

TunnelBearHelper SMLoginItem (TunnelBear, Inc. - installed 2018-03-05)

(/Applications/TunnelBear.app/Contents/Library/LoginItems/TunnelBearHelper.app)

1Password mini SMLoginItem (AgileBits Inc. - installed 2018-03-16)

(/Applications/1Password 6.app/Contents/Library/LoginItems/2BUA8C4S2C.com.agilebits.onepassword4-helper. app)

RevisionsHelper SMLoginItem (Mac App Store - installed 2018-02-20)

(/Applications/Revisions.app/Contents/Library/LoginItems/RevisionsHelper.app)


Internet Plug-ins:

AdobePDFViewerNPAPI: 17.012.20098 (installed 2018-02-25)

QuickTime Plugin: 7.7.3 (installed 2018-01-24)

AdobePDFViewer: 18.011.20038 (installed 2018-02-25)


Safari Extensions:

Shortly.safariextz - Zhusee (ZZHC) - http://zzhc.org/shortly/ (installed 2018-01-07)
Save to Pocket.safariextz - Read It Later, Inc. - http://getpocket.com/ (installed 2018-01-10)
Adblock Plus.safariextz - Eyeo GmbH - https://adblockplus.org/ (installed 2017-12-29)
Translate.safariextz - SideTree.com - Apps for Mac - http://SideTree.com/extensions.html#Translate (installed 2018-01-23)
Clip to DEVONthink.safariextz - DEVONtechnologies - http://www.devontechnologies.com/redirect.php?id=download-extras (installed 2017-12-29)
1Password.safariextz - AgileBits - https://agilebits.com/onepassword (installed 2017-12-29)


3rd Party Preference Panes:

GPG Suite (installed 2017-11-30)

Hazel (installed 2018-03-14)


Time Machine:

Skip System Files:

Mobile backups:

Auto backup: Yes

Volumes being backed up:

f**t: Disk size: 249.85 GB - Disk used: 144.24 GB

Destinations:

s**e [Local] (Last used)

Total size: 750.00 GB

Total number of backups: 71

Oldest backup: 2017-07-19 10:35:29

Last backup: 2018-03-16 21:34:14


Top Processes by CPU:

Process (count) Source % of CPU
backupd Apple 21
WindowServer Apple 17
Safari Apple 7
com.apple.WebKit.WebContent (3) Apple 4
hidd Apple 1


Top Processes by Memory:

Process (count) Source RAM usage
kernel_task Apple 904 MB
LaunchBar 433 MB
Safari Apple 421 MB
mdworker (18) Apple 350 MB
com.apple.WebKit.WebContent (3) Apple 295 MB


Top Processes by Network Use:

Process Source Input Output
ocspd Apple 23 MB 988 B
Dropbox Dropbox, Inc. 68 KB 615 KB
mDNSResponder Apple 76 KB 48 KB
Revisions Mac App Store 9 KB 16 KB
apsd Apple 5 KB 18 KB


Top Processes by Energy Use:

Process (count) Source Energy usage (0-100)
WindowServer Apple 11
mds_stores Apple 4
mds Apple 4
lsd (3) Apple 3
Safari Apple 3


Virtual Memory Information:

Available RAM 2.25 GB
Free RAM 136 MB
Used RAM 5.75 GB
Cached files 2.12 GB
Swap Used 17 MB


Software Installs (past 30 days):

Name Version Install Date
Revisions 3.0.1 2018-02-20
Byword 2.8.2 2018-03-07
Things 3.4.1 2018-03-07


Diagnostics Information (past 7 days):

2018-03-15 16:43:08 Path Finder.app CPU (once)

2018-03-12 11:14:01 suggestd Crash (once)

Detected over-release of a CFTypeRef


End of report

Mar 16, 2018 3:30 PM

Reply Helpful

Mar 16, 2018 3:58 PM in response to Charles Butcher In response to Charles Butcher

Disabling Safari extensions mostly allows the problem images to display, but often only once. Reloading the page sometimes triggers black. Clicking to display the large version often triggers black. Dragging an image to the desktop always triggers black. It seems very random. I've not been able to isolate a single extension that makes a difference on its own.

Mar 16, 2018 3:58 PM

Reply Helpful

Mar 17, 2018 8:30 AM in response to Eric Root In response to Eric Root

Thanks again. Quitting TunnelBear and removing Rogue Amoeba's Instant-On extension did not help. Nor did turning off Little Snitch, but I suspect that to test LS properly I'd have to uninstall it, and I don't have time to do that at the moment.


I'm going to leave it there for now. So far I've not seen the problem beyond these four particular PNG files, so it's not a big issue. I suspect it might have to do with how these particular files were prepared using ImageAlpha. Perhaps someone else in the future will find this thread and we'll have new evidence to work with.

Mar 17, 2018 8:30 AM

Reply Helpful
User profile for user: Charles Butcher

Question: Some PNGs render black in Safari