Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: My iPod touch uses iOS 6.1.6 I want to update to iOS8 . When I try to update I get the message your software is up to date.

update iPod touch iOS6 to 8?

Posted on

Reply
Question marked as Apple Recommended
Answer:
Answer:

Your 4th generation iPod Touch can't upgrade past 6.1.6.

Posted on

Page content loaded

User profile for user: luisafromderby

Question: My iPod touch uses iOS 6.1.6 I want to update to iOS8 . When I try to update I get the message your software is up to date.