Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: HomeKit geolocation doesn’t work

Hi,


i’ve set automations to turn on different lights when no one’s at home and when someone’s home. Problem is, it seems like HomeKit believes someone is always at home. The automation with the condition that no one’s at home doesn’t seem to work.


In general, what I’m trying to achieve is to turn the living room lights when the house is empty upon my arrival.


Did anyone encounter this issue, or get such automation to work properly?


thanks

iPhone 4S, Windows 7

Posted on

Reply

Page content loaded

Mar 18, 2018 7:13 AM in response to loadstone007 In response to loadstone007

Hi loadstone007,

Thanks for using the Apple Support Community. I understand that you have automations set up for HomeKit but they are not responding the way that you would like them to.

I recommend to take a look through the following article regarding HomeKit automations, specifically this section:

Get help with your home hub

If you have issues creating automations or controlling your HomeKit accessories when you're not home, follow these steps:

  1. Make sure that your HomePod, Apple TV, or iPad is:
  2. Make sure that you can control your accessories in the Home app on your iOS device. Open the Home app and turn on a light or change the temperature.
  3. Make sure that your device is set up as a home hub:
    • For HomePod, open the Home app on your iOS device, tap User uploaded file, then check under Home Hubs to see if HomePod is connected.
    • On your Apple TV, go to Settings > Accounts > iCloud and make sure that your Apple TV shows HomeKit as Connected. If you don’t see HomeKit, then your Apple TV isn't connected as a home hub.
    • On your iPad, go to Settings > Home and make sure that Use this iPad as a Home Hub is turned on.
  4. Restart your Apple TV, iPad, and iPhone.
  5. Wait a few minutes. If you still need help, sign out of iCloud on your Apple TV, then sign back in. Go to Settings > Accounts > iCloud.

Get help with location-based automations

If you can't create location-based automations, follow these steps:

On your iPhone, iPad, or iPod touch:

  1. Go to Settings > [your name] > iCloud.
  2. Scroll down and tap Share My Location.
  3. Make sure that Share My Location is turned on. Then tap From and make sure that your primary device is selected.

On your Apple TV:

  1. Go to Settings > General > Privacy and make sure that Location Services is turned on.
  2. Select Location Services.
  3. Make sure that HomeKit is set to Always.

If you're still having trouble after going through those steps, it may help to completely delete the automations you're having trouble with, and then set them back up.

Turn off or delete an automation

To enable or disable an automation, tap the automation, then turn Enable This Automation on or off.

To delete an automation, tap the automation, then tap Delete Automation or swipe left over the automation and tap Delete.

Automate and remotely access your HomeKit accessories

Let me know how these steps work out for you.

Best regards.

Mar 18, 2018 7:13 AM

Reply Helpful (1)
User profile for user: loadstone007

Question: HomeKit geolocation doesn’t work