Announcement: Upgrade to macOS Mojave

With features like Dark Mode, Stacks, and four new built-in apps, macOS Mojave helps you get more out of every click. 
Find out how to upgrade to macOS Mojave >

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.


Question: Network access issue on 5 GHz frequency

I have recently encountered a problem accessing my home wifi network. I have an iMac, MacBook Pro and iPhone all using our home wifi network via a range extender. While the iMac has been connecting successfully without an issues, both the MacBook and iPhone stopped connecting. All 3 devices are using the same Apple ID and share mail, bookmarks, etc., and have been getting along perfectly prieviously. The MacBook opened the usual splash window with the "The Wi-Fi Network "***********_5GEXT" could not be joined. BlahBlahBlah", and the iPhone was saying that the password was incorrect.

Note: there had been no changes to any of the devices prior to this problem - no new apps, changes to System Preferences, etc., and no problems since the last Mac OS update. Also, both computers are mostly in the same room so the issue is unlikely to be location.

I tried every piece of advice I could get but nothing worked up to and including re-installing the system - but nothing fixed the connection issue. Finally, I turned off iCloud in the iPhone, restarted the MacBook into Recovery Mode, erased the Macintosh HD and reinstalled the Mac OS. This solved the problem on both devices, and worked for several days, but has just happened again.

I have been abled to connect the MacBook and iPhone to the 2.4 GHz frequency and get connected, but the 5 GHz frequency simply cannot be accessed.

Note: the iMac and my Roku device have both been using the 5 GHz frequency throughout this drama.

Can anyone suggest the cause? Or even where I might investigate further ... Thanks


iMac 27 inch, 2.93 GHz Intel Core i7, macOS High Sierra (10.13.3)

MacBook Pro with Retina display, 2.4 GHz Intel Core i5, 8 GB 1600 MB, macOS High Sierra (10.13.3)

iPhone 8, iOS 11.2.6

Netgear EX6100 AC750 Dual Band WiFi Range Extender

MacBook Pro with Retina display, macOS High Sierra (10.13.3), 2.4 GHz Intel Core i5, 8 GB 1600 MB

Posted on


There’s more to the conversation

Read all replies

Mar 17, 2018 11:47 PM in response to Kappy In response to Kappy

Thanks for introducing me to Keychain Access - I was able to find and remove a bunch of old stuff from years ago. I was able to find and delete all of the 5G passwords but this didn't solve my issue. I was still unable to access the 5GHz frequency.

Mar 17, 2018 11:47 PM

Reply Helpful

Mar 18, 2018 10:15 AM in response to hotkeyz69 In response to hotkeyz69

I can only guess but it would seem a problem with the Netgear range extender configuration. You need to connect it to your router in bridge mode for it to work properly with an Apple router if that is what you are using. If not then I would reset the extender and perform the connection with the router again, assuming you haven't already done this. It can't hurt to reset the router, too. And, I would try the old basic trick of turning everything off, wait 30 seconds, then turn on the modem, router, extender, and computer in this order while waiting for each one to connect before turning on the next one.

If the extender was working but does not work after the above then it would seem one should consider hardware problem.

Mar 18, 2018 10:15 AM

Reply Helpful

Mar 19, 2018 8:00 AM in response to Kappy In response to Kappy

I may be wide of the mark, but if the iMac and my Roku TV device are accessing the 5 GHz frequency though the range extender, then the issue surely has to be with the Mac Book and iPhone ??? Especially when the problem was solved for several days after erasing the HD on the MacBook and reinstalling the Mac OS. Also, on both occasions the problem occurred on the iPhone at the same time as on the MacBook - probably in response to something on the MacBook.

Mar 19, 2018 8:00 AM

Reply Helpful

Mar 19, 2018 11:33 AM in response to hotkeyz69 In response to hotkeyz69

Read this article Recommended settings for Wi-Fi routers and access points - Apple Support

And in your service provider router the settings is automatic ( it will switch between 2.4 GHZ and 5 GHZ ) and will select the best channel .

See this article also AirPort base stations: Setting up and configuring an extended wireless network (802.11n) - Apple Support

Mar 19, 2018 11:33 AM

Reply Helpful

Mar 19, 2018 11:20 PM in response to tygb In response to tygb

Actually my ISP router operates on the 2.4 and 5 GHz frequencies simultaneously. As I type this post on my MacBook it is using the 2.4 GHz frequency along with my iPhone; and my iMac, AppleTV and Roku device are using the 5 GHz.

The router and wifi extender are both correctly configured and functioning perfectly - except for the inability of the MacBook to access the 5 GHz frequency. Surely the problem is somewhere in the MacBook settings.

Mar 19, 2018 11:20 PM

Reply Helpful

Mar 20, 2018 12:00 AM in response to hotkeyz69 In response to hotkeyz69

Open air port utility through spotlight > click on edit > click on internet > internet options > see the settings as in screen shot .

User uploaded file

Again go to second settings > wireless > wireless options .

User uploaded file

These settings are for the user who is using broad band connection ( in which ip addresses changes frequently ) as dual NAT settings will not work and the user has to set off bridge mode and what off bridge mode settings will nullify NAT .

In your case the router is using both 2.4 GHz and 5 Ghz and there is a setting to save 5 Ghz , you can try to check the box of 5 Ghz in airport express and click on update , are you able to join the network . just try but I doubt it will work as there are different types of routers all around the world ,and their settings can be read in brochures .

Mar 20, 2018 12:00 AM

Reply Helpful
User profile for user: hotkeyz69

Question: Network access issue on 5 GHz frequency