Announcement: Upgrade to macOS Mojave

With features like Dark Mode, Stacks, and four new built-in apps, macOS Mojave helps you get more out of every click. 
Find out how to upgrade to macOS Mojave > https://support.apple.com/macos/mojave

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Calendar App not showing Holidays

Macbook Pro running 10.13.3 and Calendars version 10.0(2195.2.1), Weather Data from Weather Underground, copyright 2002-1017.


Does this sound right?


Anyways, I can't get Calendars to show the Holidays. I've tried checking the box, unchecking, refreshing, restarting, disconnecting from icloud and reconnecting. No luck.

MacBook Pro (15-inch, 2017), iOS 11.1

Posted on

Reply
Question marked as Solved
Answer:
Answer:

Have a read through this link Unable to re-add US Holiday Calendar - SierraOS


It was a bug but got sorted, before that though the possible fix was to check you had the correct settings selected under Language & Regions in System Preferences.

Posted on

Page content loaded

Mar 18, 2018 6:58 AM in response to sbrandongvol In response to sbrandongvol

Hi sbrandongvol,
Thanks for using the Apple Support Communities. I'm a bit unclear on the exact steps you have tried, but if you are having issues with Holidays in Calendar, you may want to double-check the settings and steps outlined in the following articles:
Show holidays and birthdays in Calendar on Mac - Apple Support
About holiday calendars on iOS and macOS - Apple Support
Regards.

Mar 18, 2018 6:58 AM

Reply Helpful
Question marked as Solved

Mar 18, 2018 1:48 PM in response to sbrandongvol In response to sbrandongvol

Have a read through this link Unable to re-add US Holiday Calendar - SierraOS


It was a bug but got sorted, before that though the possible fix was to check you had the correct settings selected under Language & Regions in System Preferences.

Mar 18, 2018 1:48 PM

Reply Helpful (1)

Mar 18, 2018 1:47 PM in response to Joseph_S. In response to Joseph_S.

I went to System Preferences, Language, and English (US) was chosen. I changed it to preferred language English (Canada), restarted computer, refreshed Calendar. Then went back in, chose English(US) again, restart, refresh and viola! The Holidays showed up!

Thank you very much!

Mar 18, 2018 1:47 PM

Reply Helpful
User profile for user: sbrandongvol

Question: Calendar App not showing Holidays