3 Replies Latest reply: Jan 30, 2007 4:31 AM by imianwilliams
imianwilliams Level 1 Level 1 (20 points)
Apologies for posting in 2 different discussion areas, but I'm not sure if this is an iTunes or a MacBook problem

http://discussions.apple.com/thread.jspa?threadID=834778&tstart=0

When I insert an audio CD in to my MacBook, the CD mounts on the desktop but doesn't appear in iTunes.

It seems that iTunes knows the disc is there, as I get the pop up box that says "accessing gracenote". But the CD just doesn't appear in the left hand pane.

I'm a fairly experienced mac user, & I've not experienced this on any of my previous machines (iBook / MacMini / Powerbook).

...any ideas?

MacBook 2Gb   Mac OS X (10.4.8)  
  • Michael Tirta Level 5 Level 5 (7,655 points)
    Hi Ian Williams

    When you click the cd icon on the desktop, what kind of file it shows on the finder windows?

    Is it like musical note icon with file name track 1 , track 2, etc?

    Try to click one of them and see if it will play automatically on iTunes.

    Does it happen only for specific cd or all of your cd.

    On iTunes preference > Advanced > Importing > choose "show CD" on CD Insert section.

    On system preference CDs & DVDs > when you insert a music cd > Open iTunes.

    Repair permission might help your problem too.

    Good Luck.
  • imianwilliams Level 1 Level 1 (20 points)
    Hi Michael.

    I had already checked everything on your list, apart from System Preferences.

    ...unfortunately, that was already set correctly. So that isn't the problem either.

    When I click on a CD track icon in the Finder window, it launches iTunes, attempts to pull the CD info from Gracenote, then stops. The CD doesn't play, ot show up in iTunes.

    CD file names seem to be ok as well. (They're aiff's, with file names in the format of "1 Audio Track" etc).

    I've also tried creating another user account, & that shows exactly the same symptoms.
  • imianwilliams Level 1 Level 1 (20 points)
    Ok, problem sorted.

    I tried trashing any preference files with "iTunes" in the file name, & that didn't work.

    So I trashed them again, also trashed the iTunes app' & re-installed iTunes from scratch.

    Everything seems fine now.

    Thanks for the suggestions though.