5 Replies Latest reply: Feb 14, 2007 10:15 AM by Transini
Transini Level 1 Level 1 (135 points)
Starting a few days ago, when one OSXS system is accessed with Server Admin, the servermgrd process immediately crashes. Could there be some file that somehow got corrupted? I've run 'repair disk' and 'repair permissions', and even did a full Disk Warrior run on the boot drive to no avail. No other changes or upgrades were done to the system to prompt this.

Server Admin[357] Server got an empty response (servermgr_info may have crashed)
crashdump[444]: servermgrd crashed

According to the servermgrd man page, this might mean that /etc/servermgrd/getsslpassphrase is returning a null string (which it seems to do when run manually). But it could also be that getserial_numberinfo() is returning null.

Is there some system file I need to regenerate?

Thx


The crash dump has this:

Command: servermgrd
Path: /usr/sbin/servermgrd
Parent: launchd [1]

Version: ??? (???)

PID: 424
Thread: 4

Exception: EXCBADACCESS (0x0001)
Codes: KERNPROTECTIONFAILURE (0x0002) at 0x00000000

Thread 4 Crashed:
0 ....ServerAdmin.servermgr_info 0x0027c39c ServerSerialNumStrValidateInternal + 68
1 ....ServerAdmin.servermgr_info 0x0027a038 getserial_numberinfo + 232
2 ....ServerAdmin.servermgr_info 0x002695a8 getserverinfo + 132
3 ....ServerAdmin.servermgr_info 0x00268a60 doProcessInput + 248
4 servermgrd 0x000064e8 0x1000 + 21736
5 servermgrd 0x00008c3c 0x1000 + 31804
6 servermgrd 0x00008270 0x1000 + 29296
7 servermgrd 0x00007af8 0x1000 + 27384
8 com.apple.Foundation 0x9295d194 forkThreadForFunction + 108
9 libSystem.B.dylib 0x9002b508 pthreadbody + 96


Dual 2GHz PPC / 400GB / 8GB   Mac OS X (10.4.8)  

Dual 2GHz PPC / 400GB / 8GB   Mac OS X (10.4.8)  

Dual 2GHz PPC / 400GB / 8GB   Mac OS X (10.4.8)  
  • Transini Level 1 Level 1 (135 points)
    Well, servermgrd is still crashing, 100% of the time, but the crash has "morphed" a bit:

    Thread 5 Crashed:
    0 libcups.2.dylib 0x91b224e4 ippDelete + 36
    1 ...ple.S5Admin.servermgr_print 0x00437994 doidle_zerotasks + 85716
    2 ...ple.S5Admin.servermgr_print 0x004377f0 doidle_zerotasks + 85296
    3 ...ple.S5Admin.servermgr_print 0x00433c14 doidle_zerotasks + 69972
    4 ...ple.S5Admin.servermgr_print 0x0043527c doidle_zerotasks + 75708
    5 ...ple.S5Admin.servermgr_print 0x0042b6dc doidle_zerotasks + 35868
    6 ...ple.S5Admin.servermgr_print 0x0042b664 doidle_zerotasks + 35748
    7 ...ple.S5Admin.servermgr_print 0x00424238 doidle_zerotasks + 6008
    8 ...ple.S5Admin.servermgr_print 0x004290f4 doidle_zerotasks + 26164
    9 ...ple.S5Admin.servermgr_print 0x00428b5c doidle_zerotasks + 24732
    10 ...ple.S5Admin.servermgr_print 0x00428cbc doidle_zerotasks + 25084
    11 ...ple.S5Admin.servermgr_print 0x00421194 getservicestate + 224
    12 ...ple.S5Admin.servermgr_print 0x004205a8 doProcessInput + 204
    13 servermgrd 0x000064e8 0x1000 + 21736
    14 servermgrd 0x0000619c 0x1000 + 20892
    15 com.apple.Foundation 0x92940194 forkThreadForFunction + 108
    16 libSystem.B.dylib 0x9002bc28 pthreadbody + 96

    If anyone has any ideas about what I can do, if there's a file that I might check for corruption, something I might try reinstalling, etc., that would be great.
  • davidh Level 4 Level 4 (1,890 points)
    While servermgrd is running, get its PID, via (in the Terminal):

    ps -aux | grep [s]ervermgrd

    then look for the PID number.

    Then issue:

    sudo fs_usage -f filesys <PID>

    where <PID> is of course the one you just got via ps.

    Try using your Server Admin app and fs_usage will show you what files it's accessing. Which is not a suggestion to go removing things willy-nilly
    But it might give you a lead.
  • Transini Level 1 Level 1 (135 points)
    Thanks for great suggestion! As you may expect, there are an awful lot of files it accesses, but the file it consistently accesses just before it crashes is:

    15:13:53.907 open F=17 /private/var/servermgrd//servermgr_info.lock 0.000051 servermgrd

    It's a binary file that gets recreated every time I try to connect to the system with Server Admin.

    -rwxr-x--- 1 root wheel 307142 Feb 13 15:23 /private/var/servermgrd/servermgr_info.lock

    I don't know if that file could be the problem, since it's creating it anew each time, or if it's crashing sometime afterwards. There's plenty of disk space, and I just did a Disk Warrior rebuild on the system drive.

    So, I renamed the entire /private/var/servermgrd folder, along with the com.apple.ServerAdmin.plist, and restarted Server Admin. Still no difference! Deleting and re-adding the server doesn't help either.

    I'm at a loss to know what to try next. A server tools reinstall perhaps?


    Dual 2GHz PPC / 400GB / 8GB   Mac OS X (10.4.8)  
  • davidh Level 4 Level 4 (1,890 points)
    Hmm... might need to put that back.

    ie: /private/var/servermgrd
    or don't expect anything to work - at least the parent directory itself,
    /private/var/servermgrd
    And make sure the permissions are correct.
    drwxr-xr-x 38 root wheel servermgrd


    While it is NOT a panacea, did you run a Repair Permissions routine ?

    Try downloading the latest Server Admin tools (10.4.7)
    http://www.apple.com/support/downloads/serveradmintools1047.html

    Install the Admin Tools , repair permissions (if you haven't already), and then install the 10.4.8 combo updater BEFORE trying to use the tools (!!)
    http://www.apple.com/support/downloads/macosx1048comboupdateppc.html
  • Transini Level 1 Level 1 (135 points)
    The /private/var/servermgrd folder & contents get regenerated if they're not there.

    I ran a repair permissions on the drive, but it was fairly clean, just 2 unrelated log files showed up.

    I tried running the Server Admin Tools install package, but it tells me:
    "You cannot continue. There is nothing to install."
    This occurs even if I rename /Applications/Server, and get rid of the receipts. I looked around, but couldn't find an uninstaller. Is there one?