Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Auto sign in failure

Now when I try to sign in to some of my regular websites, when I tap the suggested ID for it that comes up above the keyboard, the suggestion fields and such all go blank, with no entry in the sign-in or password fields. All this even though the correct ID and passwords are displayed in the Settings folder. It used to work automatically and just fine, but I think things changed around the time of one of the recent iOS updates.


Now the only way to sign in is by manually filling in the ID and password. The Autofill feature appears above the left keyboard as “Autofill Contact” while I’m just typing text, but the text suggestions work okay. It’s just aggravating to have a new, expensive device that can’t auto enter sign-in info anymore.

iPad Pro Wi-Fi, iOS 11.2

Posted on

Reply

Page content loaded

Apr 21, 2018 11:01 AM in response to Hafcanadian In response to Hafcanadian

Hello Hafcanadian,


Thanks for using Apple Support Communities. It sounds like you’re having some trouble with Autofill in Safari. I’m happy to help.


To start, have you tried manually clicking into the field you’re trying to using Autofill in before selecting the information you want to autofill?


If you’ve already tried this, I suggest updating your iPad. You can find steps for doing so here:


Update your iPhone, iPad, or iPod touch - Apple Support


Once you’ve done so, make sure that iCloud Keychain is set up correctly using these steps:


Frequently asked questions about iCloud Keychain - Apple Support


Cheers.

Apr 21, 2018 11:01 AM

Reply Helpful

Apr 21, 2018 4:36 PM in response to sterling r In response to sterling r

My devices are kept updated each time I get a notification of such. I'd never turned on the Keychain feature, but did so on two iPads this time, and followed the security code instructions. It made no difference. And now the older mini-iPad that didn't seem to have a problem before is behaving the same way as the iPad Pro. As soon as I put the cursor in the ID entry field and tap the suggested ID, all the suggestion fields go blank and the circular arrow and overlapping square icons go dim, and the entry fields don't respond unless I manually enter an ID and a Password for that site. This is not a problem with all sites, but with at least one (Fred Meyer.com) that used to work just fine with Autofill.

Apr 21, 2018 4:36 PM

Reply Helpful

Apr 21, 2018 5:56 PM in response to Hafcanadian In response to Hafcanadian

Of note is the fact that I have no such issues with my old iPad2. There is no found Keychain option complicating things, and it just automatically enters the ID and Password for the Fred Meyer site just by my simply going to the website... I don't even have to tap on any ID/password suggestion fields. Newer is certainly not necessarily better.

Apr 21, 2018 5:56 PM

Reply Helpful
User profile for user: Hafcanadian

Question: Auto sign in failure