Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: iMovie Hangs at startup

When I open iMovie it starts to display but then gets in perpetual hang with "Loading... Backing up iMovie library..."

Posted on

Reply
Question marked as Solved
Answer:
Answer:

Hi,


Try opening iMovie while holding down the Option and Command keys, and selecting to delete preferences in the box that appears. Other trouble shooting procedures are: Open iMovie in a new User Account (Guest account on your Mac); Open iMovie in a new library (hold down the Option key while opening and select New in the library selection box that appears). If still problems, reinstall iMovie.


An interesting temporary solution that I saw to a similar problem is to open the Applications Folder and control-click on the iMovie icon. Then click on Show Package Contents>Contents>MacOS>iMovie (to launch).


Also, take a look at this thread to see if there is anything in there that helps you:


iMovie 10.1.3 crash


-- Rich

Posted on

Page content loaded

Question marked as Solved

Apr 22, 2018 9:32 PM in response to ChukAmuck In response to ChukAmuck

Hi,


Try opening iMovie while holding down the Option and Command keys, and selecting to delete preferences in the box that appears. Other trouble shooting procedures are: Open iMovie in a new User Account (Guest account on your Mac); Open iMovie in a new library (hold down the Option key while opening and select New in the library selection box that appears). If still problems, reinstall iMovie.


An interesting temporary solution that I saw to a similar problem is to open the Applications Folder and control-click on the iMovie icon. Then click on Show Package Contents>Contents>MacOS>iMovie (to launch).


Also, take a look at this thread to see if there is anything in there that helps you:


iMovie 10.1.3 crash


-- Rich

Apr 22, 2018 9:32 PM

Reply Helpful (1)
User profile for user: ChukAmuck

Question: iMovie Hangs at startup