Announcement: Upgrade to macOS Mojave

With features like Dark Mode, Stacks, and four new built-in apps, macOS Mojave helps you get more out of every click. 
Find out how to upgrade to macOS Mojave > https://support.apple.com/macos/mojave

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Can't install High Sierra on 2011 late year MacBook Pro

Greetings. The Apple support page that discusses upgrading current OS with late model MBP states that they should be able to load the new OS as long as it's 2009 or newer and has at least 2G of ram. Well, a late year certainly qualifies. I tried to upgrade and I had a Kernal panic. Took it into the Apple Store and the tech tried to get it to work and could not do it. He says it has to be some sort of hardware problem. But I can run Sierra just fine. What kind of hardware problem can it be? I really want to upgrade because Pages will not update iCloud documents created with my iPad 2 mini. The tech said that this is probably because I don't have the latest OS on the MBP.

MacBook Pro

Posted on

Reply

Page content loaded

There are no replies.
User profile for user: mattgolfs

Question: Can't install High Sierra on 2011 late year MacBook Pro