Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Capture Last Take

I was a beta tester for Emagic before it became Logic and then consulted with Apple after they purchased. All that to say, lately I've become so frustrated with the program that I'm now testing Studio One and FL Studio. The last straw for me was when Capture Last Take stopped working as the name suggests, "Capture Last Take." It now captures EVERYTHING!!!! I have had the same work flow for years when it comes to recording, which means, I NEVER use the record option. I like working on parts and the ability to hit Shift-Return and record what I just played without always having the extra step of going in and out of record. However, Apple changed this and I've spent months on the phone trying to find a work-around. After hours of experimentation, I figured out that there is a bug in Logic because it has everything to do with my transport quick keys. If anyone has figured out a way to revert back to the old way of using Capture Last Take, I would be grateful!


Keith Thomas

Final Cut Pro X, Mac OS X (10.7.5)

Posted on

Reply

Page content loaded

Apr 21, 2018 11:18 PM in response to Indyuser In response to Indyuser

Thanks for the reply. I don’t think you understood my issue. Capture Last take is not Capture Last Take any longer. It’s Capture Last 20 Takes. The DAW only used to Capture the last bit you played on the keyboard I’ve been round and round with Apple but they seemed to be blind to the way it was and the way it is now or perhaps they feel they’ve improved it which is not the case. Even Protools now has Capture Last Take the way Logic used to work.

Apr 21, 2018 11:18 PM

Reply Helpful

Apr 21, 2018 11:20 PM in response to thomboykt In response to thomboykt

your are also referring to Apple’s key commands. I have my own set (Autoload) that i’ve been using since Apple’s acquisition of Logic.

Apr 21, 2018 11:20 PM

Reply Helpful

Apr 22, 2018 8:25 PM in response to thomboykt In response to thomboykt

I cannot reproduce this issue - I am running 10.4.1 and it is only capturing the last take only.... Maybe you can provide a little more detail i.e. exact process in order for me to duplicate what you are seeing...and what version you are running ?

Apr 22, 2018 8:25 PM

Reply Helpful

Apr 23, 2018 6:26 AM in response to Indyuser In response to Indyuser

Thank you for trying! This is somewhat encouraging. Try the following process and see if CLT works. Hit play, play a sequence of notes on your controller. Hit stop, (Obviously don't play on the controller), hit play again, play a completely different sequence of notes and hit stop. Select Capture Last Take. On my system all the notes from both sequences will be there regardless of the preference settings, which only the notes from the last sequence you played should be captured. Perhaps try it several times back to back as if you're working on a part and you finally got something you like. Try it in the loop mode as well as stopping and starting. Historically I could do both without changing any prefs.

Apr 23, 2018 6:26 AM

Reply Helpful

Apr 23, 2018 9:41 AM in response to thomboykt In response to thomboykt

That is really strange and it looks like it is a specific issue on your system.

I never experienced that and I never use the Record button for MIDI recording, only the Caputure feature.


You Logic is playing and you play notes on your MIDI Keyboard, those notes will be recorded in a buffer in the background. If you press stop, then those notes only stay in the buffer until you press play again and Logic receives new MIDI messages. At that moment the buffer is erased and filled with the new MIDI notes you are playing.


I don't think it is a bug in Logic. I would start trying to troubleshoot your system, to find out why it is behaving that way.



Hope that helps


Edgar Rothermich - LogicProGEM.com

(Author of the "Graphically Enhanced Manuals")

http://DingDingMusic.com/Manuals/

'I may receive some form of compensation, financial or otherwise, from my recommendation or link.'

Apr 23, 2018 9:41 AM

Reply Helpful

Apr 24, 2018 12:18 AM in response to EdgarRothermich In response to EdgarRothermich

Edgar, Thanks so much. You‘re 100% correct regarding Capture Last Take. This started happening on my rig with a particular Logic update that I can’t remember at the moment, but Apple was able to help me revert back to the previous version, which I used for quite a while, avoiding all Logic updates until I had to do a fresh install on my computer and had to install the latest version of Logic. Capture Last Take has not worked correctly since. I‘m suspicious that my autoload, which I’ve used for well over a decade, is somehow playing a role. Oddly enough, my engineer is having the same issue on his rig. I need to find out if he’s using my autoload. Regarding my system, it’s a new Mac Pro. The problem originated on my previous Mac Pro. I certainly appreciate you and everyone‘s effort to help resolve this issue.


Keith Thomas

keiththomas.com

Apr 24, 2018 12:18 AM

Reply Helpful

Apr 24, 2018 4:12 AM in response to thomboykt In response to thomboykt

I tried again last night using various permutation, recording setting, cycle mode etc and as long as you hit stop between pressing play - capture last take only records the very last take. So it does sound like something incorrectly configured on your system.

You might want to start by exporting your key commands to save them and then factory resetting . Disabling the autoload and start with a fresh clean project native to the version you are running... etc...

Apr 24, 2018 4:12 AM

Reply Helpful

Apr 24, 2018 10:59 AM in response to thomboykt In response to thomboykt

Well I've discovered it has something to do with previously assigned shortcuts. I started using Logic's shortcuts and CLT worked as it's supposed to. I've slowly started integrating my old shortcuts and so far so good. My brain is wired to the old shortcuts though so hopefully I'll be able to assess and report back the conflict. Reminds me when Apple removed command M from the shortcut options a few years back, which was my merge regions. 6 months later I was still minimizing the window and had to reopen. Thanks again for taking the time to experiment with this! Much appreciated.


Keith Thomas

Apr 24, 2018 10:59 AM

Reply Helpful
User profile for user: thomboykt

Question: Capture Last Take