Announcement: Upgrade to macOS Mojave

With features like Dark Mode, Stacks, and four new built-in apps, macOS Mojave helps you get more out of every click. 
Find out how to upgrade to macOS Mojave > https://support.apple.com/macos/mojave

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: iMessage time issues

I have a MacBook Pro (13 inch, late 2013) with MacOS High Sierra and an iPhone SE with iOS 11.3. My friend with an iPhone SE and an iPad has this issue as well.


Basically, sometimes when I'm having a conversation with someone over iMessage, I'll send a message. And then they'll send a message. And their message will show up before mine. Even though I sent mine first.


And then on my Mac, it gets even worse. The order of my iMessages will get mixed up, and all theirs will show up before all mine, even if they're sending new messages - they just go straight to the top, before all my messages. So something I sent 10 minutes ago will often end up being "more recent" than one I had sent 5 minutes ago. And something they just sent will show up as being older than all of mine.

Plus, you know you when you hold the mouse over a message, it shows the time? It'll show up that I sent a message at 2:17 PM when the current time is 2:05 PM. Or that I sent a message at 9:02 PM when I sent it at 8:21 PM. Or that I sent a message at 9:14 PM when I sent it at 8:36. But then the next message I sent will show up as the correct time.


This issue didn't show up on my Mac until I updated it to macOS High Sierra.


I'd really like to know how to fix this because it's really inconvenient, and I've tried doing a bunch of things to

MacBook Pro with Retina display, macOS High Sierra (10.13.3)

Posted on

Reply

Page content loaded

Apr 23, 2018 12:51 PM in response to maddie012 In response to maddie012

Hi,


There still does not seem to be an instant fix for this.


The obvious places to check are:-

System Preferences > Date and Time including the time Zone and the Time Server.


Check the router's Time server


Check the Location setting on both iPhone and Mac and or iPad, particularly if you have travelled.

Restart the computer with NVRAM reset https://support.apple.com/en-gb/HT204063

This does do some basic maintenance not doe when you do a normal Restart.


On the Mac change the Sort Messages option in View to Manually, Quit Messages then Restart before turning the setting back to sort by Date (it includes Time).


If you have other things you have tried we could do with knowing what they were before we offer the same suggestions again and again.



User uploaded file

8:51 pm Monday; April 23, 2018


 iMac 2.5Ghz i5 2011 (Sierra)
 G4/1GhzDual MDD (Leopard 10.5.8)
 MacBookPro 2Gb (Snow Leopard 10.6.8)
 Mac OS X (10.6.8),
 iPhone 6 iOS 11.x and an iPad (2)

Apr 23, 2018 12:51 PM

Reply Helpful
User profile for user: maddie012

Question: iMessage time issues