Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Logic Pro X Compatibility

Hey ,


Im running El Capitan on 2008 Mac Pro and i found out that i can't buy the new Logic.


can i somehow buy ( LEGALLY ONLY ) Logic in a version that will work with my OS ?


Thanks.

Logic Pro X, OS X El Capitan (10.11.6)

Posted on

Reply

Page content loaded

There are no replies.
User profile for user: DreamlandProject

Question: Logic Pro X Compatibility