Announcement: Upgrade to macOS Mojave

With features like Dark Mode, Stacks, and four new built-in apps, macOS Mojave helps you get more out of every click. 
Find out how to upgrade to macOS Mojave > https://support.apple.com/macos/mojave

Related Article

Resolve issues caused by changing the permissions of items in your home folder

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: On iMacPro/High Sierra how to reclusively change permissions on an external hard disk?

1. I am working on my new iMac Pro (OS=latest High Sierra) with 1T ssd.


2. ssd on iMac works perfectly so no problem there. I did not migrate from my old Mac Pro since I wanted to sort my old work first and keep my iMac leaner.


3. All my heavy graphic work from my old Mac Pro is on a new WD-4T hard disk connected to my iMac, but without any System on it. Works great, but the 4T permissions are yet a problem (and its 3/4 full of folders!).


4. Permissions on my iMac are fine but unless I change permissions on the 4T, every time I do something, I must Authenticate or enter my pwd.


5. I now tediously change permissions on my 4T and on some of its main folders and sub-folders, but permissions on lower folders or docs do not change, even though I go through the "Get Info," add Administrator and "User=Me," and "Apply to enclosed items."


5. I have thought of using the Terminal syntax "$ chmod -R +rw" or "$ chmod -R +rwX"plus folder/dir name, but my Terminal is addressing my iMac Pro, and I may mess up my ssd by doing this.


QUESTION: How to change permissions "globally" (recursively) on my external (no-system) 4T hard disk, and if via Terminal, what is the syntax?


Much anticipated and appreciated answer. Jim

Mac Pro, OS X Mountain Lion (10.8.2)

Posted on

Reply

Page content loaded

Apr 22, 2018 11:55 AM in response to 1750Jim In response to 1750Jim

I don't know why you are doing this, but the easiest solution on a drive not used as a startup volume is to select the disk's Desktop icon and press Command-I to open the Get Info window. At the bottom is the Sharing & Permissions panel. Click on the tiny lock icon then enter your admin password when prompted. Check the box to, Ignore permissions on this drive. The following will set all proper permissions for a boot volume.


Boot into single-user mode and at the prompt enter these commands pressing RETURN after each:


mount -uw /

chown root:admin /

chmod 1775 /

reboot


After rebooting open Terminal in the Utilities folder. Paste these commands into the Terminal application to avoid typos:


sudo su


Press RETURN. Enter your admin password when prompted. It will not be echoed to the screen. Press RETURN again. Now paste each of the following at the prompt and press RETURN after each.


chown root:admin /Applications

chmod 0775 /Applications

chown root:admin /Library

chmod 1775 /Library

chown root:admin /System

chmod 0775 /System

chown root:admin /Users

chmod 0775 /Users

chmod -R -N /Applications

chown -R :admin /Applications/*


I suggest you first print these instructions out using a large mono-spaced font so you can read them correctly. There are spaces in the lines that may not be easily observed.

Apr 22, 2018 11:55 AM

Reply Helpful

Apr 22, 2018 1:57 PM in response to 1750Jim In response to 1750Jim

Thanks for such a quick and clear reply, Kappy. I would have done this had the "Ignore permissions on this drive" appeared, but it is no where to be found on my Sharing & Permissions panel for my external WD-4T, and it is scrolled down to the very bottom.


When I got my new iMac I dragged all my old MacPro boot drive's folders and files (but not system, of course) over to my new external WD-4T drive, as well as folders and files from a second internal drive on the MacPro. Could the folders and files from my old MacPro boot disk be the cause of now not showing the "Ignore permissions on this drive" on my 4T's Sharing & Permissions panel?

Apr 22, 2018 1:57 PM

Reply Helpful

Apr 22, 2018 3:15 PM in response to 1750Jim In response to 1750Jim

How is this drive partitioned and formatted? Is it using the GUID partition schema and Mac OS Extended, Journaled format type?


If anything you have on that drive consists of a bootable system then the Ignore permissions option is generally there. It is there on all my drives that contain bootable systems. It is only absent on the selected startup drive. As you see below it is present on my other bootable drive which is not my present startup drive.

User uploaded file

Apr 22, 2018 3:15 PM

Reply Helpful

Apr 22, 2018 6:14 PM in response to Kappy In response to Kappy

Thanks much, Kappy.


Very interesting. It does not appear on the 4T drive (nor on the iMac's ssd drive which is no doubt the way that works). It also is not on my MacPro boot drive (HD) but is on my MacPro second internal HD that is not bootable. Something going on for some reason. Here is what the Info on the 4T external HD. You can see that I have snapped enough to show the entire window. Yes, it is a GUID partition.

User uploaded file


User uploaded file

Apr 22, 2018 6:14 PM

Reply Helpful

Apr 22, 2018 7:48 PM in response to 1750Jim In response to 1750Jim

I see that 'everyone' is set for r/w. Maybe that's why the other checkbox is missing. Or it would appear that there is a valid system on the drive - 10.12.6. Normally, everyone would be read-only. The drive is marked as a system drive because 'system' is marked as r/w.


I still don't quite know what the actual problem is. Originally, there was just data on this drive then you transferred an older system disk's entire content to this drive. You did not give the details of these transfers, i.e., how they were done. I don't know why you are changing permissions since you should never need to do that.

Apr 22, 2018 7:48 PM

Reply Helpful

Apr 22, 2018 9:03 PM in response to Kappy In response to Kappy

I've been trying your ideas, Kappy,. Here is a summary.

1. Took System off the Sharing and Permissions

2. Tried to take "everyone" off, too, but it is greyed so changed it to Read only.

3. With your comment about System I realized that it could not be there unless some System was present on 4T.

4. I found that there was a "System" folder but that it only had "Library" in it. I now recall that I had done this in case I had to bring something over to legitimize my authorization for the Adobe CC. Not too smart of me.

5. Put that System with Library in trash and rebooted, but still no "Apply to enclosed" items option in Get Info.

6. No System folder now on 4T, *but* Get Info still allows me the option of adding "System" which must mean that the 4T still thinks there is a System Present.

7. I also found a "User" folder on the 4T that should not be there. Moved it to trash unmounted and mounted 4T but still the same (snap below).

7. Perhaps I should empty trash and try again to reboot.

8. I thought I had only brought over data folders and files (copied from MacPro to iMac by dragging via ethernet). Perhaps the fact that i had the System with Library and the User folder (both from the MacPro) created the problem in the first place.

Apr 22, 2018 9:03 PM

Reply Helpful

Apr 22, 2018 9:07 PM in response to 1750Jim In response to 1750Jim

Forgot to include the snap below. I did close the Get Info panel and Got Info again, but nothing changed. I don't know where you are but it may be late. I can still function by changing permissions manually for each folder I need to use. Once I change permissions for a folder, it appears to remain on reboot. However, I still would like to solve this problem. Late here so will retire now. Thanks for your patience!


User uploaded file

Apr 22, 2018 9:07 PM

Reply Helpful

Apr 23, 2018 12:19 PM in response to 1750Jim In response to 1750Jim

In order to put the correct disk permissions on the drive you will need to do this. Open the Get Info window and click on the lock to authenticate. Now, open Terminal in the Utilities’ folder and paste the following command:


sudo chown root:wheel /Volumes/wd4t_180215




Press RETURN. When prompted enter your admin password. It will not be echoed to the window. Press RETURN again. Close and re-open the Get Info window and see if the proper permissions are there. Should be: system r/w, wheel r/w or r-only, and everyone r-only.

Apr 23, 2018 12:19 PM

Reply Helpful

Apr 23, 2018 6:01 PM in response to Kappy In response to Kappy

Thought you'd given up on me, Kappy. Great to received your post!


I've followed your instructions precisely, three times, even one time including the spaces in Terminal before the sudo ... syntax.


Results: My 4T HD permissions came out the same every time = system r/w and everyone r-only, but no wheel r/w or r-only (below). I realize that the "su" of "sudo chown ..." should bring up the wheel, but it doesn't. This may not make a difference.

User uploaded file


The "Get Info" for top folders on the 4T still read as I set them today (hoping to solve the problem. I deleted the 'wheel"and the 'fetching..." (sometimes two 'fetching"s) and changed these top folder to read as follows (below). Hope I did not mess things up by this but thought that might be the only solution, i.e., do it all manually. Here is what my top folders in the 4T now look like (after doing who you say above, and below that, a sample of a sub-folder that I have not altered.


1. My top folders all look like this

User uploaded file


2. A sample of a sub-folder, unaltered, but not all exactly like this

User uploaded file


Last night I deleted every remnant of a system related folder (e.g., Library, User, etc., plus the top System folder which was empty except for the Library. Took sometime to delete (100,000+), and of course I could not delete the empty folder of System or System/Libraries since High Sierra does not allow deleting what it deems should not be deleted. Thus I connected the 4T to my lap top (with an earlier OS) and got rid of them that way.


Sorry to be so wordy, but with all of your help I fear leaving some needed info out. Thanks again for your expertise.

Apr 23, 2018 6:01 PM

Reply Helpful

Apr 23, 2018 7:19 PM in response to 1750Jim In response to 1750Jim

Well, that's OK as it is, I suppose. You are the 'owner' instead of 'system.' If you aren't going to boot a system on that volume it shouldn't make any difference, although it wouldn't make any difference operationally.


I'm concerned about the sub-folders. They should not be 'Fetching.' It shows you have custom access which usually means an unrecognized permission. You may be able to change that by using the permissions for the main drive entry in the first image. You see the drop-down tools image on the lower left?

User uploaded file

Click on 'Apply to enclosed items' to extend the same settings to all folders below this level. See more on this here, Resolve issues caused by changing the permissions of items in your home folder. You can use the earlier post to fix all disk permissions for a startup disk. But it might make more sense to get rid of the macOS system so that all you have on the disk are the files you would store there. You could then put them all into a separate folder then change the permissions for that folder and apply the change to all enclosed items.

Apr 23, 2018 7:19 PM

Reply Helpful

Apr 23, 2018 7:42 PM in response to Kappy In response to Kappy

I always use the "Apply to enclosed items" but have found that this only refers to files and not folders inside the folder. It has consistently done this, i.e., changed files but not folders both in the 4T drive or in the top folders in that drive. BTW, there is no System or remnant of the System visible on the 4T, but something must be telling the drive that a system is there. Strange.


Your suggestion of putting all the files in a separate folder is good except that my top folders in the 4T have sub-folders and sub-sub-folders, and changing permissions on folders above them has no effect on folders, only on files.


Do you suggest that I try the solution in the last link you sent me ("Resolve issues caused....")? I pasted the procedure in below. Might that be a solution. I would do this only when I have Get Info up for the 4T drive. If so, what should my permissions look like before I choose "Apply to enclosed items" and go into Terminal?


Many thanks!


_____________________From "Resolve issued caused ..."

  1. When the progress bar completes, open the Terminal app, which is in the Utilities folder of your Applications folder.
  2. Paste or type this command in Terminal, then press Return:
    diskutil resetUserPermissions / `id -u`

Apr 23, 2018 7:42 PM

Reply Helpful

Apr 23, 2018 7:54 PM in response to 1750Jim In response to 1750Jim

That should work if the command is valid. These also should work:

To fix Home folder permissions


Open the Terminal application in the Utilitie's folder. At the command line prompt enter or paste the following command line:


sudo chown -R `id -un`:`id -gn` ~


Press RETURN. You will be prompted to enter your admin password which will not be echoed.



Repair Permissions for Home Folder


Boot into Single-user Mode then enter each command line pressing RETURN after each:


chmod -R -N /Users/username

chown -R username:staff /Users/username

chmod -R 600 /Users/username


After each command has been run restart the computer by entering:


reboot

Apr 23, 2018 7:54 PM

Reply Helpful

Apr 23, 2018 8:10 PM in response to Kappy In response to Kappy

Questions:

1. What permissions would be ideal for the external 4T for it to work with any computer, the ones you suggested earlier?


2. Concerning the Terminal syntax: diskutil resetUserPermissions / `id -u`

a. Are you sure that this syntax will address only the 4T (and not the boot ssd drive)?

b. You imply that it won't since you send the syntax for Home folder permission.


I simply do not want to mess up permissions on my ssd boot drive on my iMac. Thanks!

Apr 23, 2018 8:10 PM

Reply Helpful

Apr 23, 2018 8:21 PM in response to 1750Jim In response to 1750Jim

The 'normal' ones are:


Owner = you with r/w privileges.

Group = staff with r/o privileges.

= everyone with r/o privileges.


As you have written it will affect the boot volume. Change it to


diskutil resetUserPermissions /Volume/wd4t_180215 `id -u`


I don't think the ` after the -u belongs there. Never used this command. I would check the man pages for diskutil. Also, I don't know if you will need sudo ahead of the diskutil.

Apr 23, 2018 8:21 PM

Reply Helpful
User profile for user: 1750Jim

Question: On iMacPro/High Sierra how to reclusively change permissions on an external hard disk?