Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Wireless Not Connecting-No IP address

A few months ago, my built-in Airport card stopped working.

Under System Profiler, I now do not have an airport card listed


I bought a third-party, USB external wireless adapter instead. It’s TP-Link Archer T4U AC 1300 Wireless Dual Band


I installed the drivers, and it worked for a month, and has now stopped working. Symptoms are:


In the menu at the top right, it shows wireless routers, it lets me choose mine and enter the password. So that function seems to be working.


However, in the Network Preferences, it shows Wi-Fi Not Connected. I have Configure IPv4, set to: Using DHCP. It does not show an IP address, etc where it should show up.


And, I wonder if this means anything: When I click Wi-Fi, under Status, it says: Cable Unplugged - Either the cable for Wi-Fi is not plugged in or the device at the other end is not responding. This seems weird and wrong, that the wording for Wi-Fi talks about a cable, which it shouldn't.


It seems like the driver or something is halfway working, since it shows my wireless router/network, but it’s not connecting to, not sending the right signal to the Network Preferences/Mac OS.


When I plug in the external USB wireless adapter, what goes to the top of the list is: Thunderbolt Bridge, and gives a Self-Assigned IP.


The TP-Link company had me try a couple of different drivers, but that has’t worked. The USB external adapter does work in a Windows computer, so the device is working.


I can get online on my MacBook if I plug an ethernet cable in, and the internet also works with Personal Hotspot on my iPhone, if I plug a USB-iPhone cable in, so it works otherwise.


I have a MacBook Pro, 2.2 Ghz i7, Early 2011, Mac OS X 10.9.4


Here are a couple of screen shots, if this helps:

Here it is connected to my Cisco Router, this works, let me enter the password.

User uploaded file


Here is the Network Preferences, with no IP address, and “Cable Unplugged"

User uploaded file


Thanks for any help anyone can provide!

MacBook Pro, OS X Mavericks (10.9.4)

Posted on

Reply

Page content loaded

User profile for user: Tree_Farmer

Question: Wireless Not Connecting-No IP address