Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Captions not exporting

Hey guys, I have the latest FCP and I've just uploaded a video to YouTube, only to find that all the captions are missing? There were no error messages when exporting.


I thought maybe YouTube stripped it for some reason so just to check I decided to export to the Desktop. Now I'm getting the "has missing or offline titles, effects, generators, or media" message. I exported it anyway only to find that the captions are still missing.


Running High Sierra 10.13.4


Any ideas?


Peter

MacBook Pro with Retina display, macOS High Sierra (10.13.4)

Posted on

Reply

Page content loaded

Apr 23, 2018 8:34 AM in response to BonzerPete In response to BonzerPete

If you export a master file, your captions, if enabled, will be on a separate file.

If you are exporting for youtube and the export is failing somehow (like, in this case, the captions not being there on youtube), try deleting the youtube destination in FCP X and creating a new one. It worked for me.

Apr 23, 2018 8:34 AM

Reply Helpful

Apr 24, 2018 2:39 AM in response to Luis Sequeira1 In response to Luis Sequeira1

I checked the roles section and the only thing I can enable is exporting captions as a second file. I don't want that I want it to be part of the video. Whats the point of having captions if they're not exported with the video.

Apr 24, 2018 2:39 AM

Reply Helpful

Apr 24, 2018 2:49 AM in response to BonzerPete In response to BonzerPete

I think you are misunderstanding what captions are.

Captions are not subtitles. By definition, they are separate, and can be turned on or off.

It seems to me that you want to "burn in" the subtitles as part of the video.


If you have used captions as an alternative to subtitles, you may want to look at an application by spherico (Andreas Kiel), called

"X-Title Caption Convert", which can turn captions into subtitles.


http://www.spherico.de/filmtools/

Apr 24, 2018 2:49 AM

Reply Helpful
User profile for user: BonzerPete

Question: Captions not exporting