Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Why don't I qualify for High Sierra?

I saw a YouTube video that suggested my MacBook Pro 5,5 (2009) was capable of running High Sierra, but every time I try to download it, Apple says no.

Mac OS X (10.1.x), Safari , iCloud?

Posted on

Reply

May 26, 2018 7:11 AM in response to Music908 In response to Music908

Don't believe what you see in YouTube.

You need a MacBook Pro (Mid 2010 or newer) model


Mac Hardware Requirements


For details about your Mac model, click the Apple icon at the top left of your screen, choose About This Mac. These Mac models are compatible with macOS High Sierra:

  • MacBook (Late 2009 or newer)
  • MacBook Pro (Mid 2010 or newer)
  • MacBook Air (Late 2010 or newer)
  • Mac mini (Mid 2010 or newer)
  • iMac (Late 2009 or newer)
  • Mac Pro (Mid 2010 or newer)

May 26, 2018 7:11 AM

Reply Helpful
User profile for user: Music908

Question: Why don't I qualify for High Sierra?