Announcement: Upgrade to macOS Mojave

With features like Dark Mode, Stacks, and four new built-in apps, macOS Mojave helps you get more out of every click. 
Find out how to upgrade to macOS Mojave > https://support.apple.com/macos/mojave

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: iMac won't stay with my preferred wifi network

There are several wifi networks in my home, one created by my Velop system and two by my cable modem. Obviously, since I went to the expense of buying the equipment for a mesh network, and have peripherals attached to it, I want my computers to use it. Nevertheless, when my iMac awakens from sleep, it regularly joins the cable network. The iMac sees and gets a good signal from my Velop network (one of the nodes is 2 meters away!) and I can switch to it with no difficulty, but I want it to join automatically. "Automatically join this network" is checked in System Preferences > Networks. None of the several other computers in the house, or my iPhone or iPads, display this behavior.


It is probably irrelevant, but maybe not, that this iMac (21.5", just a few years old and running High Sierra) can be infuriating at times, with exasperating idiosyncrasies, including excruciating slowdowns – when I signed on to post this question, and had to enter a verification code sent to my iPhone, it took FIFTEEN SECONDS for all of the digits to appear in the blanks onscreen, one every couple of seconds, after I'd entered them in quick succession on the keypad – as well as sometimes taking the better part of one minute to launch or quit Mail. And the computer wasn't doing anything else – I had just turned it on. And it refuses to stop asking for 2FA even though I'm not blocking any cookies. Probably unrelated, but just sayin'.

iMac, macOS High Sierra (10.13.4), 21.5-inch, 2013

Posted on

Reply
Question marked as Apple recommended
Answer:
Answer:

In network preferences move the preferred network to the top of the list. Your computer will then first try to connect to this network before falling to the ones lower in the list.

Posted on

Question marked as Apple recommended

May 29, 2018 11:34 AM in response to hlritter In response to hlritter

In network preferences move the preferred network to the top of the list. Your computer will then first try to connect to this network before falling to the ones lower in the list.

May 29, 2018 11:34 AM

Reply Helpful

May 29, 2018 11:41 AM in response to hlritter In response to hlritter

Maybe the simplest fix, since it is a desktop that you rarely move around to any other location.

In Preferences > Network > Wi-Fi > Advanced > Wi-Fi

remove ALL the other networks (via the minus - sign), and ONLY have the Velop node available,

since you already have the "automatically join this network" option enabled.

This way, it has no other choice to automatically join...

May 29, 2018 11:41 AM

Reply Helpful
User profile for user: hlritter

Question: iMac won't stay with my preferred wifi network