Previous 1 2 Next 17 Replies Latest reply: Feb 11, 2007 4:41 AM by Majordadusma
Robertaa Level 1 Level 1 (15 points)
Hey Gary,
or any other techs listening, my G4 seems to only recognize music CD's. It just spits out any of my install disks when trying to boot for basic utility checks etc.


Roberta

Quicksilver 800 MHz PowerPC G4 1.25 GB SDRAM, Mac OS X (10.3.9), G-Drive 250GB, HP 7310 All in one, Netgear wireless router
  • Thomas Bryant Level 6 Level 6 (13,865 points)
    Hello! Are you holding down the "c" key at startup? And also are the discs the Retail Version of Panther and not one for a particular model? Tom
  • Majordadusma Level 6 Level 6 (9,425 points)
    Hi, Tom!

    Some background:

    Roberta has worked another issue involving Photoshop Elements not working in Classic on her QS G4. (Here's the thread, which contains some pertinent background info.) Working with both issues in differing directions got a bit messy there and she started a new topic for this issue.

    Here's what I believe to be the scenario so far, unless I misunderstood/missed something:

    In the course of troubleshooting the Classic/PE issue, she could not get her retail Panther disc, original Mac OS X 10 disc or her OS 9 install disc to C-boot so that she could run Repair Disk from the install disc. Option-booting via startup manager did not help with the Panther disc...

    She did a Safe Boot to run the file system check, but she has not yet tried fsck from Single User Mode. She did a Permissions Repair from DU on the startup volume.

    Roberta also originally had a "disk full" message before moving her image files to an external drive, leaving her with 11(+)GB free space on the startup drive.

    Any thoughts you have on this are appreciated!

    Gary






    1GHz DP G4 Quicksilver 2002, 400MHz B&W rev.2 G3, Mac SE30   Mac OS X (10.4.5)   5G iPod, Epson 2200 & R300 & LW Select 360 Printers, Epson 3200 Scanner
  • Majordadusma Level 6 Level 6 (9,425 points)
    Roberta,

    I'd recommend that you try a couple of things. First, launch Disk Utility from the startup drive and run Repair Permissions again. You should end up with a message that states that the permissions have been successfully repaired.

    Next, run fsck (file system check) from Single User Mode, which is similar to running Repair Disk with Disk Utility. Restart your Mac while holding down the cmd+s keys, which will cause your Mac to boot to a command line screen. Type the following command at the prompt that appears, followed by pressing the return key:

    /sbin/fsck -fy (press return)

    The Mac will check the startup volume, reporting just like Disk Utility does. Give it time to run it's course. When it has completed, it will either report that the volume appears to be okay, or instead may report that the volume has been successfully repaired. If the latter is reported, run the above command again until it reports that the volume appears to be okay. When you get the volume appears to be okay message, type the following command at the prompt, followed by the return key, at which point your Mac will restart normally to your startup drive:

    reboot (press return)

    If for some reason, you get mixed up while on the command line screen, you can safely just shutdown with the power button, as long as the fsck routine isn't still running.

    Once you've accomplished the permissions repair and fsck, insert your Panther install disc #1 into the optical drive and restart while depressing the cmdoption+pr keys until your hear the second startup chime, after which you should release these keys and immediately depress and hold the "c" key for at least until the spinning cogwheel appears. The Mac should boot to the Panther install disc.

    Any luck? If not, try starting up to the Startup Manager (hold down the option key at startup) and see if the install disc image appears on the screen once the tiny clock icon disappears. If it does, highlight the install disc and then click the right-facing arrrow to boot to the disc.

    Please let us know what happens...

    Gary

    ps: Thank you for the "helpful" award, but you might instead save these for someone here who provides some real "keys" towards a solution for you, for which we're certainly rooting!

    1GHz DP G4 Quicksilver 2002, 400MHz B&W rev.2 G3, Mac SE30   Mac OS X (10.4.5)   5G iPod, Epson 2200 & R300 & LW Select 360 Printers, Epson 3200 Scanner
  • Robertaa Level 1 Level 1 (15 points)
    Hi Gary,,
    I repaired permissions again.
    did the /sbin/fsck -fy (press return) on the black screen.

    It read: no such file or directory

    Did the /sbin/fsck -fy (press return) again .....waited

    Got appears to be ok.

    Insterted disc #1 and restarted cmdoption+pr.......NOPE JUST SPIT THE CD OUT.

    Tried the option key at start up
    install disk did not appear only the start up disk OSX, tried to select the start up disk, (no selection available)
    went to right arrow button, cd spit out, then OSX login screen came up.

    logged in, mouse was weird, slow, selected three items on the desktop to trash, once selected they hung on the pointer and would not drop to the trash. Could not get them off the pointer, pointer did not work to select anything so.......
    restarted with the power button.

    here we are.
    any ideas much appreciated!

    Roberta



    G4 Mac OS X (10.3.9)
  • Majordadusma Level 6 Level 6 (9,425 points)
    Roberta,

    Check to see if your install discs (Panther, OS 9, original OS X) will load and mount to the desktop while you're normally running in OS X. If not, load a data CD and see if that mounts.

    Are you the original owner of this Mac? Are the gray OS X and OS 9 discs definitely those that originally shipped with this G4?

    Reset NVRAM in open firmware: Shutdown, then boot to open firmware by starting up with the CMDoption+"o""f" keys depressed. When the command line screen appears, type the following commands at the prompts, each followed by the return key:

    reset-nvram (press return)
    reset-all (press return)

    The Mac should boot normally after the second "return". Retry loading an install disc to see if it mounts to the desktop. Any luck now?

    BTW - What is your hard drive capacity and how much available sapce is now showing?

    Gary

    1GHz DP G4 Quicksilver 2002, 400MHz B&W rev.2 G3, Mac SE30   Mac OS X (10.4.5)   5G iPod, Epson 2200 & R300 & LW Select 360 Printers, Epson 3200 Scanner
  • Robertaa Level 1 Level 1 (15 points)
    Install discs will not load.

    I am the original owner and completed a 0 all data in early 2002. This unit had been a demo for a short time.

    All disks are the original.

    Panther disks are upgrade disks.

    Did the NVRAM all went well.

    Reboot went well.

    Install disk did not mount. Just spit out again.

    Drive Capacity 38.18GB w/ 10.58GB Available

    Roberta
  • Thomas Bryant Level 6 Level 6 (13,865 points)
    Hello Again! Is it possible that the discs are not the ones you think they are? You said it's been a demo model. Some of the QS shipped with various Versions of the OS and trying to startup from a disc of an earlier version than it shipped with may cause problems. Just a thought, Tom.
  • Robertaa Level 1 Level 1 (15 points)
    These are the only disks I've ever had.
    Since I did a 0 all data and then installed from these disks, would it matter?

    I've done other boots from these disks I'm sure. Can't remember why, but I know that I've gone through this process before.

    I've never had any issues with any of these disks before.

    That's 5 years.

    Roberta
  • Majordadusma Level 6 Level 6 (9,425 points)
    Roberta,

    Strange problem! Please confirm that other, non-boot discs still properly load and mount to the desktop.

    Also, you should have a bootable Apple Hardware Test disc that came with your Mac. Please load it into the optical drive and C-boot to the disc. If it boots, please run it and let us know if it passes the test.

    It's highly unlikely that all three of your install discs are bad. They should at least mount to the desktop while you're running normally, even if they won't boot the Mac. If you have a cleaning CD, you might run it in the optical drive to clean up the laser lens.

    Do you have access to another Mac? (e.g. friend, work, school, nearby Apple Store.) If so, you could confirm that your install discs will indeed load properly on another machine (even if they may not boot), which will help hone in on the issue. If they do load, then the likely culprit is the optical drive, though the Mac's memory settings or possibly something on your hard drive might still play a role in this.

    Are you comfortable with working inside the G4 to do some things like re-seating cables?

    Gary
  • Robertaa Level 1 Level 1 (15 points)
    Hi Gary,
    I don't have time to do some of the tries tonight.
    My dad is a mechanical engineer and I'm not afraid of much if I have the right directions, ie manuals, diagrams, etc. No prior training of my own though. I did add the memory card, but that's all I've done inside this Mac.
    Will my CD's read on a new G5? I'll try asap.

    Roberta
  • Robertaa Level 1 Level 1 (15 points)
    Hi Gary,
    My OSX disk mounted right away on my sisters G5, so
    I cleaned both the disk and the drive.
    tried to get it to mount on the desktop. No go.
    Restarted with the disk in,
    restart seemed slow.
    I realized I had a photo card / disk image mounted on the desktop, (probably why the start up seemed slow)
    I drug the photo/disk image to the trash and
    BINGO
    THE OSX install disk image mounted.

    I restarted and booted with the C key down
    It seemed to be ok
    then I got a error message that read:
    Disk Utility internal Error
    disk utility has lost its connection w/ the disk management tool and cannot continue. PLease quit and relaunch Disk Utility.

    then: Error message, Operations still in progress , quitting in the middle can leave a disk non-opperational. Are you sure you want to quit?

    pressed don't quit and it went back to repairing permissions
    it took 5 minutes without moving so I stopped the repair process and got the print in red Stopped by User. this did not seem to do anything. I waited again for 5 min or so and
    decided to quit Disk Utility.

    What should I do next?

    oh, I did try to get the OSX disk to mount to the desktop again, and it would not.

    Roberta

    G4 Mac OS X (10.3.9)
  • Robertaa Level 1 Level 1 (15 points)
    Tried a few more things.
    installed the Apple Hardware Test CD, first try it did not show up on the desktop, second try it did.
    I unhooked all periphials and tried again.
    Shut down completely, started up with the C key down.
    My Mac just spit the CD out.

    This seems so hit and miss, do I need a new CD drive.
    If so which one? I do not have a DVD and I would like to
    upgrade to a combo or a new CD and a new DVD any suggestions?

    Still listening, hope I don't have to wait until Monday.......

    Roberta

    G4 Mac OS X (10.3.9)
  • fragmore Level 3 Level 3 (660 points)
    Just read all your comments, reccommend you take your computer and disk to a certified Mac repair tech.
  • Robertaa Level 1 Level 1 (15 points)
    I'm curious, did you go back in the original thread?
    For the most part the computer works fantastic in all os apps.
    I don't have a problem with taking it in but I'm not clear on what I should tell them.

    Roberta
Previous 1 2 Next