4 Replies Latest reply: Jun 4, 2007 7:33 AM by spliszka
ipod nancy Level 1 Level 1 (0 points)
Itunes can no longer find my library of music. I have verified under advanced preferences that itunes is looking in the correct folder for the music. Two months ago, I moved all of my music to a new hard drive, changed the music folder settings and had everything working fine. No, itunes no longer recognizes any of the music even though I can find it via Windows Explorer. If I go to the song file via Explorer and launch it, it will then show up in itunes. My previous music library file is over 6 months old. What can I do to have itunes recognize my music again?

Dell, Windows XP
  • The Mimico Kid Level 6 Level 6 (10,325 points)
    Hi, ipod nancy.

    The settings for the iTunes Music folder in the iTunes Edit menu > Preferences > Advanced tab > General sub-tab don't tell iTunes where to look for the music that's in your Library but rather where to put the music that it adds to the Library.

    As for your problem, you may have to explain the situation a bit more clearly but is it possible you didn't have the external drive connected and powered on before running iTunes? This is known to cause problems.
  • huntermillington Level 1 Level 1 (0 points)
    Opened up my iTunes and poof....no library ! Where did it go ?
  • ryan jones3 Level 1 Level 1 (5 points)
    hi, i am experiencing the same problem as you by the sounds of it.
    If anyone can help please do!
    My i tunes has been fine for ages.
    Turned it on today and my songs came up as normal in the library, but when i tried to play one it came up with the tell tale ! next to the song, and said it couldn't locate it. I tried another and that was same, then another, and so on. you get the picture. Every single song has the ! next to it.

    I then went into my docs/my music/itunes/itunes music, where the tunes are stored. they are all still there and i havent changed any folder names etc.

    Once i click the song file directly it will play no problem and then i tunes will recognise it as normal.

    Why would this have suddenly happend?

    dell dimension   Windows XP  
  • spliszka Level 1 Level 1 (0 points)
    I went to Advanced and can't find the option:
    General sub-tab don't tell iTunes where to look for the music that's in your Library but rather where to put the music that it adds to the Library.
    Can I click on something to have iTunes not look for the music? How can I get rid of "!" when I go to a song?