Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Java plug-in no longer in Safari 12.0

After seeing an update for Safari today, I noted that it contained security updates, so I upgraded. After upgrading, however, I could no longer launch a Java applet for remote desktop access that I've used for years. The upgrade put Safari at version 12.0 (13606.2.11). There no longer is a Java plug-in under the list of available plug-ins that can be enabled/disabled for individual web sites. Specifically, it used to look like this:

User uploaded file

Now I now longer see Java in the list of plug-ins at the lower left. I re-installed JRE 8 Update 181 from Oracle to no avail. How are we supposed to run Java applets/applications from Safari in version 12.0 and later? My MacOS is Version 10.13.6 (17G65).

MacBook Air, macOS High Sierra (10.13.6)

Posted on

Reply

Sep 18, 2018 2:19 AM in response to JMCanning In response to JMCanning

I am having the same issue - in my case my Java app works but there I need to enable the "Unsafe" mode for the Java App and that has also disappeared.


I am assuming there is a workaround or the feature is hidden somewhere else....waiting...😕

Sep 18, 2018 2:19 AM

Reply Helpful

Sep 18, 2018 7:28 AM in response to Eric Root In response to Eric Root

I don't think that's correct. I still see other plug-ins for Adobe Flash, Google Talk, etc. The screenshot below is from my newly installed Safari 12.0

User uploaded file

What's the basis for your assertion that plug-ins are no longer supported?

Sep 18, 2018 7:28 AM

Reply Helpful
Question marked as Solved

Sep 18, 2018 8:57 AM in response to Eric Root In response to Eric Root

After reading more (see How to Use Java, Silverlight, and Other Plugins in Modern Browsers and https://jaxenter.com/clock-ticking-java-browser-plugin-will-deprecated-soon-1315 46.html), Safari has been one of the longest browsers to support the NPAPI Java plug-in. That support seems to have ended with Safari 11. There are some alternatives according to the jaxenter.com article, but they require modifying the Java application.

Sep 18, 2018 8:57 AM

Reply Helpful

Sep 23, 2018 1:32 PM in response to JMCanning In response to JMCanning

I'm having the same problem with 5 different Macs within the family (iMac, 2 new MacBook Pros, 1 old MacBook Pro, and 1 old MacBook Air). The use a program that requires Java plugin support and now I can't use it after the upgrade to Safari 12.0. I tried everything and was finally able to wipe an old 2013 MacBook my kid used before she got her new Mac this year. It came back with Safari 10.12 after the install which allowed me to use the Java plugin. Unfortunately, I can't do that easily for the rest of my computers because the shipload of software and documents. Now the only device I can run Java on is old and heavy MacBook. I used the new MacBook or MacBook Air when I travel but now I can't do that. I have to carry that old computer just to use 1 program?


Apple has been controlling and now they are getting more and more controlling. If Java is NOT safe then a user should be able to use it on their own risk. All Apple has to do is give the warning!


This has to change.

Sep 23, 2018 1:32 PM

Reply Helpful

Sep 29, 2018 7:33 AM in response to Jeanhh1936 In response to Jeanhh1936

If you have a backup, you can restore your computer to a backup made prior to installing Safari 12. Individual applications included as part of the OS can't be restored.


If you are running 10.13.6, boot into the Recovery Partition and reinstall the OS.

Sep 29, 2018 7:33 AM

Reply Helpful

Oct 8, 2018 12:55 PM in response to Eric Root In response to Eric Root

I am having the same problem. I was using Safari to access a remote desktop - which requires the Java plug-in.


Now I am blocked out and have no way of backing up or reinstalling the old Safari to enable this remote access. Does anyone know how to do that? And have a copy of the old safari? Until this is fixed I am locked out.


help is appreciated.

Oct 8, 2018 12:55 PM

Reply Helpful

Nov 2, 2018 8:25 AM in response to new maria In response to new maria

I hope this is not too late, but I too depend on a Java plugin to connect to work. I found in another article that using "SeaMonkey" from the Mozilla group did the trick! https://www.seamonkey-project.org

It includes an email, newsgroup, and feed client too but I only use it as a browser for my Java-Plugin required applications. Now I am back online and saving Safari and all those other browsers I tried (with no avail) for other uses.

Hope it works for you -- I am recommending it to all my cohorts who telecommute with Macs to try it out.

Nov 2, 2018 8:25 AM

Reply Helpful (2)
User profile for user: JMCanning

Question: Java plug-in no longer in Safari 12.0