Question:

Question: ios 12 imessage streamlining

Is there a way to turn off the streamlining of imessages in ios 12? My ex-wife and our 2 teenage daughters share an apple ID. With the new "benefit" of streamlining in ios 12, all of their messages to and from me are lumped (streamlined) together. I can only send a text to the last one of them that texted me. This is not a benefit, not safe, and not conducive to being able to communicate quickly and easily.

iPhone 8, iOS 12

Posted on

Reply
Question marked as Solved
Answer:
Answer:

They need to stop starting an Apple ID and set up Family Sharing.


There may be some data loss, but you can minimize it. If syncing photos with iCloud, ensure Optimization is turned off in Settings/Your Name/iCloud/Photos and/or in Photos/Preferences/iCloud. Then make sure full resolution photos are on the device/computer. When signing out of iCloud, if asked whether you want to retain data, choose yes. Messages conversations will be lost if they are addressed to the ID. See the article below for other places that the old ID should be removed. Also set up Family Sharing to keep access to your apps. Also see Winston Churchill's response in the below discussion


Apple ID – Create


How to transfer all files from one iCloud account to another


Apple ID email address or password - What to do after you change

Family Sharing



Family Sharing - Use your own Apple ID for Family Sharing


Family Sharing -What types of content can I share?



Family Sharing - If you don‘t see your family‘s shared content


Family Sharing - Ask to Buy


Family Sharing - Ask to Buy - Get Help



Family Sharing - purchases and payments



Family Sharing - Hide and unhide music, movies, TV shows, audiobooks, and books



Family Sharing – share iCloud Storage



Family Sharing - Share an iCloud storage plan with your family


Family Sharing and location



Family Sharing and Apple ID for your child


Posted on

Question marked as Helpful

Sep 24, 2018 4:24 AM in response to kevinfromwendell In response to kevinfromwendell

FYI I seem to of found a workaround! I removed any other email address to associated with my main Apple ID Then I created Apple IDs with those email addresses for my wife and kids. If it’s for kids make sure you set the birthdate to at least 13 years old or it has to be shared with an adult Apple ID . Then on each of the devices I logged in separately with those accounts to iMessage and FaceTime. And left the main Apple ID the same on all the Devices. Seems to work for now.

There’s more to the conversation

Read all replies

Page content loaded

Question marked as Solved

Oct 2, 2018 3:47 AM in response to raftgide In response to raftgide

They need to stop starting an Apple ID and set up Family Sharing.


There may be some data loss, but you can minimize it. If syncing photos with iCloud, ensure Optimization is turned off in Settings/Your Name/iCloud/Photos and/or in Photos/Preferences/iCloud. Then make sure full resolution photos are on the device/computer. When signing out of iCloud, if asked whether you want to retain data, choose yes. Messages conversations will be lost if they are addressed to the ID. See the article below for other places that the old ID should be removed. Also set up Family Sharing to keep access to your apps. Also see Winston Churchill's response in the below discussion


Apple ID – Create


How to transfer all files from one iCloud account to another


Apple ID email address or password - What to do after you change

Family Sharing



Family Sharing - Use your own Apple ID for Family Sharing


Family Sharing -What types of content can I share?



Family Sharing - If you don‘t see your family‘s shared content


Family Sharing - Ask to Buy


Family Sharing - Ask to Buy - Get Help



Family Sharing - purchases and payments



Family Sharing - Hide and unhide music, movies, TV shows, audiobooks, and books



Family Sharing – share iCloud Storage



Family Sharing - Share an iCloud storage plan with your family


Family Sharing and location



Family Sharing and Apple ID for your child


Oct 2, 2018 3:47 AM

Reply Helpful (2)

Sep 21, 2018 7:42 PM in response to Eric Root In response to Eric Root

I have this same problem! My family of 4 shares one Apple IDs. We shared this before family sharing was a thing. But the main reason is because of iTunes Match. We have iTunes Match and Apple music family. But iTunes Match isn’t shareable and Apple Music is horrible for having live version of songs on the studio albums. It’s so irritating so the only way we can listed to the real version not the live is to use or iTunes Match Library. Is there a way to turn off ios12 streamlined messaging or is there a work around to prevent this but still all have access to one single iTunes Match account?

Sep 21, 2018 7:42 PM

Reply Helpful (2)

Sep 22, 2018 10:42 AM in response to raftgide In response to raftgide

I have the same issue and share the same concerns - I have been on with apple support for the last hour with no resolution. The message below points out the solution of simply not sharing an apple ID - we were originally encouraged to share the ID before family sharing was a thing - once you have MASSIVE numbers of PAID FOR songs it isnt right that they then change the rules so you no longer can listen to your music depending on whether you use your wifes phone or yours.

Sep 22, 2018 10:42 AM

Reply Helpful (2)

Sep 22, 2018 11:07 AM in response to davidfromdavenport In response to davidfromdavenport

Wow I hope they fix this! In the mean time I’m going to try and remove thier iMessage emails from my main account and create a Apple ID for each one. Then I’m going to try and just log in with these accounts for just iMessage and face time. Then use my main Apple ID for everything else! 🏻 Hope it works! I’m so **** frustrated with this. I personally think they should of made it a option where you could toggle off streamline messsaging!

Sep 22, 2018 11:07 AM

Reply Helpful (3)
Question marked as Helpful

Sep 24, 2018 4:24 AM in response to kevinfromwendell In response to kevinfromwendell

FYI I seem to of found a workaround! I removed any other email address to associated with my main Apple ID Then I created Apple IDs with those email addresses for my wife and kids. If it’s for kids make sure you set the birthdate to at least 13 years old or it has to be shared with an adult Apple ID . Then on each of the devices I logged in separately with those accounts to iMessage and FaceTime. And left the main Apple ID the same on all the Devices. Seems to work for now.

Sep 24, 2018 4:24 AM

Reply Helpful (1)

Sep 25, 2018 9:37 PM in response to Eric Root In response to Eric Root

This is unacceptable. My husband has the same Apple ID for his work phone and personal phone. If the last message he sent was from his work phone, that’s the only phone I can text without having to delete the entire thread. Make this an option Apple. I’ve never wanted to switch from an iPhone until now. I can’t stand messages merging from two different phones.

Sep 25, 2018 9:37 PM

Reply Helpful (1)

Sep 26, 2018 6:15 AM in response to arogers591 In response to arogers591

Apple doesn’t routinely monitor the discussions. These are mostly user to user discussions.


Send Apple feedback. They won't answer, but at least will know there is a problem or a suggestion for change. If enough people send feedback, it may get the problem/suggested change solved sooner.


Click here to send Feedback

Sep 26, 2018 6:15 AM

Reply Helpful (2)

Sep 27, 2018 6:24 PM in response to raftgide In response to raftgide

Also experiencing the pain of not being able to text my wife and daughters' phones using iMessage. We were all under one AppleID, but last night we each established our own AppleIDs and set up Family Sharing, but still having the same issue with iMessage. Can't even send SMS messages properly after turning iMessage off. There must be some reason for this. I have removed the common email address that was on both my and my wife's vCard, but that had no effect. The kids didn't have that email address in their vCards. I think we're migrating our conversations to Facebook Messenger until Apple gets this straightened out.

Sep 27, 2018 6:24 PM

Reply Helpful

Sep 28, 2018 1:46 PM in response to christagna In response to christagna

I had this same problem when I shared apple id with my kids. I set up new apple id's for each person and set up family sharing. I made sure that icloud, messages, and facetime were all using the new apple id for each person on their device, but left the shared apple id for iTunes and Apps on each device. After I did all of this, I was still having the issue with the merged imessages text string. I then deleted the "infected" text string (the one where all the shared apple id's were showing up). After I deleted the text string, I was able to text each individual person again! For some reason, getting rid of the "infected" text string was what prevented the solution of new apple id's from taking over. All is good now and all works!

Sep 28, 2018 1:46 PM

Reply Helpful

Sep 29, 2018 11:48 AM in response to 3boymom3 In response to 3boymom3

Thank for this! I did not change any of our Apple Ids yet but went ahead and deleted the “infected” text string with all 3 kids combined text after the IOS 12 update. It seems to be working now. Fingers crossed Apple doesn’t do another update and this same thing will happen again. I could not text my kids individually for a week. I would prefer not to do family share.

Sep 29, 2018 11:48 AM

Reply Helpful (1)

Oct 1, 2018 2:28 PM in response to raftgide In response to raftgide

I’m a little confused. So are you saying delete all text strings with the people who are experiencing this problem? We had 1 ID. Then set up individual ones. Still have the problem. Our family can’t text each other. If I text my wife it goes to my daughter. Everyone in my family is experiencing similar problems. The only way we can text is through a group text. Apple can’t figure it out.

Oct 1, 2018 2:28 PM

Reply Helpful (1)

Oct 1, 2018 7:31 PM in response to denis624 In response to denis624

I only had to delete 1 text string because everyone I shared the Id with “merged” I to 1 string. So if it is you, your wife and your daughter, whoever text you last is how the string should be showing up in your list of messages. Delete that text string.

Oct 1, 2018 7:31 PM

Reply Helpful
User profile for user: raftgide

Question: ios 12 imessage streamlining