Announcement: Upgrade to macOS Mojave

With features like Dark Mode, Stacks, and four new built-in apps, macOS Mojave helps you get more out of every click. 
Find out how to upgrade to macOS Mojave > https://support.apple.com/macos/mojave

Question:

Question: WiFi: No Hardware Installed after Mojave upgrade

I installed Mojave on my MBP (early 2015, 2.9GHz, 16MB ram) the other night and now have issues... in addition to God awfully slow performance, my WiFi no longer works... I have a “WiFi: No Hardware Installed” message where the signal indicator should be... all worked fine before the install.


I have run the AHT and no problems were found... I have tried booting in safe mode, I have reset the NVRAM, I have SMC, I have deleted the NetworkInterfaces.plist and rebooted... none have corrected the WiFi problem (or the slow performance)...


Anyone have other ideas?

Posted on

Reply
Question marked as Solved
Answer:
Answer:

Finally found a solution, thanks to this post: Re: Mojave login UI sluggish & laggy


If you're booting from a usb drive, make sure to edit the file on the right volume. My MBP is now back to being healthy and working perfectly on Mojave... with WiFi!


TL;DR - on the native drive (/Volumes/Macintosh HD), got to /etc/ and rename the sysctl.conf file, reboot and voila!

Posted on

Question marked as Helpful

Oct 10, 2018 5:04 PM in response to Josh Hill In response to Josh Hill

Fixed it! It is amazing to me that one tiny config file can bring down the whole system! I followed the instructions of someone else in the replies below (forgot the name) and Mohave installed without a hitch. Here are the instructions:


If you're also seeing symptoms like networking failing, bluetooth devices not connecting, etc, and you have been using the mac for a while (or restored it from another machine using migration or time machine), then it's due to an old, out of date system configuration file that is contains settings that are too low for modern macs: '/etc/sysctl.conf'
This file doesn't even exists on new macs, so if you have it, it will cause problems

A. If you can log in (even if slow), or you're still on High Sierra, and have not yet upgraded, follow these instructions:


1. Start the terminal app from Applications/Utilities


2. Check if the file exists, by typing

ls -l /etc/sysctl.conf


If this returns a result like the following, then the file exists. If it does not, then your issues are caused by something else

-rw-r--r-- 1 root wheel 136 24 Nov 2013 /etc/sysctl.conf


3. Remove the file: (actually this command will simply rename it, so you can restore it if you really want to mess up your computer again.)

You'll be prompted for your password.

sudo mv /etc/sysctl.conf /etc/sysctl.conf.bak


4. Restart your computer, and you should be all set, or if you've rolled back to High Sierra, you should be good to attempt the upgrade again.



B. IF you are unable to successfully log in at all (usually those who are running encrypted disks), then you're going to have to do a couple of steps first.


  1. 1. Reboot in to 'recovery mode' by holding cmd-R when you power on the computer until you see the apple logo.
  2. 2. You'll be presented by a menu with the 4 recovery options. One of them is 'disk utility'. Click on it to load disk utility.
    3. Disk utility displays a list of the drives/partitions on your computer. One of these will be called something like 'Macintosh HD'. Select it. Next, On the top right hand corner of the disk utility window is a series of icons, one of which is called 'Mount'. Click on this. If you disk is encrypted, it may ask you to type in your password to unlock it. Do so.
  3. 4. Quit the disk utility app. This should take you back to the recovery menu.
    5. Launch the Terminal app as follows: In the top main menu bar is a menu called 'Utilities'. Open this menu, and you should see 'terminal'. Click on it to launch.
    6. From terminal, rename the troublesome file:
    mv /etc/sysctl.conf /etc/sysctl.conf.bak
  4. 7. Exit terminal, and restart your mac. You should be able to log in successfully.

There’s more to the conversation

Read all replies

Page content loaded

Sep 29, 2018 7:39 AM in response to Josh Hill In response to Josh Hill

Same problem here with my early 2015 MBP. It slowed down to the speed of a 486 DX2 80mhz with Turbo off, WiFi says No Hardware Installed and wired connection wont work.


Also tried NVRAM, SMC reset and also doing a reinstall from the recovery console (not a clean reinstall, need my files). No luck.


Also tried the USB Ethernet dongle and that’s not working either.

Sep 29, 2018 7:39 AM

Reply Helpful (1)

Sep 30, 2018 8:06 PM in response to Josh Hill In response to Josh Hill

I will also add that it does not recognize my thunderbolt/ethernet adapter... it appears to be a Mojave issue as both work when booting in recovery mode.

Sep 30, 2018 8:06 PM

Reply Helpful

Oct 2, 2018 9:09 AM in response to Josh Hill In response to Josh Hill

My experience is the same on a late 2015 iMac. I tried the same things as you did and it does not work. I created a new user, and new network locations as well. No joy. My hardware is there and works when booting into Recovery. Applecare's solution was to roll back. Hopefully an update is forthcoming.

Oct 2, 2018 9:09 AM

Reply Helpful

Oct 2, 2018 7:48 PM in response to Josh Hill In response to Josh Hill

I am so ******!


I have an iMac Retina 5K, 27inch 2017 with 4.2GHz i7 40GB of memory.


I installed the first beta of Mojave and had this problem. Computer turned slow as molasses and I was getting the WI-FI: No hardware installed error. I tried everything to no avail and after several days, I recovered from a Time Machine backup and didn’t try again...till yesterday.


I installed the final version of Mojave, and here I am again. Same **** error. Can’t use my computer. I don’t have the time or patience to mess around for another several days so, unless I hear about some miracle fix soon, I’m downgrading again.


I’d like to use Mojave but come on! I know the hardware is installed, it will start working as soon as I downgrade.


Any thoughts?

Oct 2, 2018 7:48 PM

Reply Helpful (1)

Oct 3, 2018 1:40 AM in response to AFlyingGoose In response to AFlyingGoose

Quick update: current resolution from Apple is to bring the device to a store where they will make sure to remove all Kernel extensions (e.g., Little Snitch, AirParrot, VPNs, applications such as Parallels).

Oct 3, 2018 1:40 AM

Reply Helpful

Oct 3, 2018 3:58 AM in response to Josh Hill In response to Josh Hill

Same with my mother's computer, and it's driving us up the wall. Me because I'm hundreds of miles away trying to talk her through zapping the PRAM and all that jazz.


She's got it wired into the home network and the network panel in System Preferences shows "green" (connected) with a valid IP address, but Safari says there's no internet connection. The airport menu has an X through the icon and says there's no WiFi hardware installed when you pull it down.

I'd have her take it into a store, but the nearest Apple Store is 90 minutes away in another city and she doesn't drive. I'm going to have her call Apple today to open a ticket but it sounds like they won't be able to do anything for her.


I see that many are having the issue, which means Apple will have to address it but I have a concern: If Apple releases 10.14.1 with a fix... HOW DO WE INSTALL IT WITH NO ABILITY TO CONNECT TO THE INTERNET? Any ideas about that?

Oct 3, 2018 3:58 AM

Reply Helpful

Oct 3, 2018 6:44 AM in response to ZoeMacUser In response to ZoeMacUser

I was just wondering that. Also wondering if Mojave is worth packing my computer up to take to the Apple store when I can just downgrade to High Sierra.


FYI, I just booted into Safe Mode in Mojave and still no WI-FI hardware. Might that mean extensions are not my problem?

Oct 3, 2018 6:44 AM

Reply Helpful

Oct 3, 2018 6:45 AM in response to AFlyingGoose In response to AFlyingGoose

Have Parallels installed but none of the other software. I discussed Parallels with the Sr AppleCare tech and he stated that Parallels wouldn’t cause this problem. I have not done a clean install (erase and restore) so I’m interested to know if this will resolve the issue. If you bring it in I’m sure that is what the Apple tech will do. So make sure you have a backup. Please keep us posted.

Oct 3, 2018 6:45 AM

Reply Helpful

Oct 3, 2018 6:51 AM in response to MightyMax21 In response to MightyMax21

Tried to remove Parallels, SMCFan, iStatmenu, Sizeup, TunnelBlick (openvpn) and did a reinstall today. No luck.


Same as Ibadan - no luck in safemode.


That said, in the systems log, I keep seeing something about the installer still trying to finish the install and something constantly crashing (configd via launchd).

Oct 3, 2018 6:51 AM

Reply Helpful (1)

Oct 3, 2018 7:47 AM in response to Josh Hill In response to Josh Hill

Same issues ("WiFi: No hardware installed" and turned my Late 2014 iMac 5K 4gHz I7 with 32gb ram into a sluggish 286). Installed Mojave on an external USB 3.0 drive and booted from there with no issues. At least I can get to my files and online.


Booting from the internal Fusion drive continues to be problematic.


Ran Disk Utility / First Aid on the internal drive without finding anything.


I've an appointment at the Genius Bar tomorrow. If no success there I'll downgrade, but that means having to wipe the drive because I'll have to go back to MacOS Extended (Journaled) from APFS.

Oct 3, 2018 7:47 AM

Reply Helpful

Oct 3, 2018 7:56 AM in response to ajs3563 In response to ajs3563

Keep us in the loop!


Rebooting in safe mode did not fix my problem.


I will tell you though, I was able to downgrade from a beta to High Sierra from a TimeMachine backup without wiping my drive...or perhaps it wiped it they restored what I had 🤔


Also starting to seriously consider a clean install. I need to do some research to learn what that actually means and what I will lose in the process.

Oct 3, 2018 7:56 AM

Reply Helpful

Oct 3, 2018 12:33 PM in response to Josh Hill In response to Josh Hill

My MBP is the same as yours and I am experiencing the same. I have done the tings you listed off, as well as reinstalled Mojave through Recovery (wifi works for that part, just not in Mojave) with no luck.


Additionally, Mine isn't recognizing USB flash drives (to backup files) or the Thunderbolt Ethernet adapter either.

Oct 3, 2018 12:33 PM

Reply Helpful
User profile for user: Josh Hill

Question: WiFi: No Hardware Installed after Mojave upgrade